How do I turn off completion of closing html tags in html/jsp files?

I REALLY want to turn off completion that completes html tags. For example, I'm often making existing code into tables and whenever I type it completes the closing ]]> for me. I'd rather it not do that, but I can't find the setting to turn it off. THanks.

8 comments

Another thing that's very annoying: I'm often type the empty tag first and
then fill in internals. But when I try to type this: "" in jsp page, guess what I get? "]]>" What the hell?! Can this be turned off or tuned
somehow?
When you type two double quotes, lets say, Idea understands this and even
though it initially adds the second double quote automatically, it
recognizes me doing the same and I get what I wanted - the pair of double
quotes. But not with html tags!


0

This particular could be avoided by changing Settings|Code Completion|After
'<' in XML from 0 to some greater value.

-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

Another thing that's very annoying: I'm often type the empty tag first
and
then fill in internals. But when I try to type this: "<>" in jsp
page,
guess what I get? "<a></a>" What the hell?! Can this be turned off or
tuned
somehow?
When you type two double quotes, lets say, Idea understands this and
even
though it initially adds the second double quote automatically, it
recognizes me doing the same and I get what I wanted - the pair of
double
quotes. But not with html tags!



0

This particular could be avoided by changing Settings|Code Completion|After
'<' in XML from 0 to some greater value.[/QUOTE MAXIM]

But the above will turn off the completion for all xml. I only want it turned off for HTML/JSP

0

You'll still be able to invoke completion manually by pressing Ctrl+Space
of course. Personally I hate those immediate autocompletions and wonder now
why 0 was choosen as default value for XML completion.

-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

This particular could be avoided by changing
Settings|Code Completion|After '<' in XML from 0 to some greater
value.[/QUOTE MAXIM]

But the above will turn off the completion for all xml. I only want it
turned off for HTML/JSP



0

Maxim Shafirov (JetBrains) wrote:

Personally I hate those immediate autocompletions and wonder now
why 0 was choosen as default value for XML completion.


I feel the same way. Is there any chance it will be changed, if a
request is submitted?

Bas

0

Changing defaults is always painful since users will start reporting things
like 'auto suggestion of tag names in XML is broken'...

-


Maxim Shafirov
http://www.jetbrains.com
"Develop with pleasure!"

Maxim Shafirov (JetBrains) wrote:

>> Personally I hate those immediate autocompletions and wonder now why
>> 0 was choosen as default value for XML completion.
>>

I feel the same way. Is there any chance it will be changed, if a
request is submitted?

Bas



0

Maxim Shafirov wrote:
This particular could be avoided by changing Settings|Code Completion|After
'<' in XML from 0 to some greater value.
-



I set mine to 6000 milliseconds but I still get the tag completing after I type something like ]]>. I thought the setting above was for autopops of attributes etc? What I'm not wanting is the closing tag generated automatically after typing in the opening tag.

0

Please sign in to leave a comment.