how to remove the auto-completion of braces

Hi,

When typing methodName(... how I can stop IntelliJ from adding the closing brace ... )? Also the same goes for { } and [ ]


Thanks

2 comments
Comment actions Permalink

Use the settings, they are searchable. ;-)



IDE Settings -> Editor -> Smart Keys -> Insert pair bracket

for (), [] and in Array initializers {}

IDE Settings -> Editor -> Smart Keys -> Enter -> Insert pair '}'

for {} where you press enter, be it in array initializer or blocks like "if", "switch" and so on.

0

Please sign in to leave a comment.