How do I debug JSP files?

Hi,

I have been able to debug JSP files in the past (prior to my computer crash). However now,
after re-installation, I can't get it to work anymore for some strange reason.

I configure up Tomcat 6 in a normal fashion and debugging works fine for normal Java files,
but not for JSP files.Is there any special trick to this that I should know about?

I'm running Windows 7 64 bit, Tomcat 6.0.26 and jdk1.6.0_20

I have tried this in both Idea 8.1.4 and 9.0.2, but have reverted back to 8.1.4 since Idea 9
works so poorly.

Any help would be most appreciated!

Thanks,
Jonas

4 comments

Is the directory containing your jsp file configured as 'Web resource directory' in Web Facet settings?

Hi,

>

I have been able to debug JSP files in the past (prior to my computer crash). However now,
after re-installation, I can't get it to work anymore for some strange reason.

>

I configure up Tomcat 6 in a normal fashion and debugging works fine for normal Java files,
but not for JSP files.Is there any special trick to this that I should know about?

>

I'm running Windows 7 64 bit, Tomcat 6.0.26 and jdk1.6.0_20

>

I have tried this in both Idea 8.1.4 and 9.0.2, but have reverted back to 8.1.4 since Idea 9
works so poorly.

>

Any help would be most appreciated!

>

Thanks,
Jonas

>

---
Original message URL: http://devnet.jetbrains.net/message/5266893#5266893



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

No, I hadn't enabled and configured the web facet correctly. I didn't know this was needed... until now.

It works fine now :-)

Thanks for your help!

0

Hi,
I have a similar problem. Could you please let me know how you configuredthe web facet?

Thanks

0

Please sign in to leave a comment.