Is it possible to let Find... only scroll the document after you press enter?

Hello,

Often when pressing CTRL+F, the Find function scrolls the page to an old search result. This changes the location in the page where I am and affects the position from which I want to search a new search term.

Is there a setting in IntelliJ, or a plugin, or any other way, to let IntelliJ 10's find not scroll the page in any way until you've pressed enter?

Thanks!

9 comments
Comment actions Permalink

Hello,

Just checked that under 10.5 that when I hit Ctrl+F at the editor, search text field is empty and the viewport doesn't change it's position. Can you provide a screencast that shows what happens at your environment?

Denis

0
Comment actions Permalink

Hello,

I've restarted IntelliJ, and now the input field of Find is empty if I close and reopen it. So the problem is gone, for now :) Before I restarted it, the input field always showed the same old search term. Whenever searching for something, then closing and reopening find, it was filled with that same old search term and jumping to that part of the page. I didn't manage to find out how to change the value of this old search term it was filling in when opening it, to something else.

Could this be a bug?

EDIT: It's doing it again. I don't know exactly how it started happening, but at one point I had some text selected and pressed CTRL+F, and the focus didn't go to the search box for some reason. Now, whenever pressing CTRL+F, the focus does go to the search box, but that one string I had selected back then is always filled in it by default, and the page scrolls to the first found result of that word whenever pressing CTRL+F and before pressing enter. I use split screen by the way, if that could have any influence...

0
Comment actions Permalink

So when you select some text, that is what appears in the search box. For all I know, it seems to think that if I *don't* have any text selected, that I actually have that one string it always displays selected!

0
Comment actions Permalink

Thanks for the info!

Looks like a bug, will try to reproduce it locally.

Denis

0
Comment actions Permalink

I think I found what causes it:

It's when selecting something and then using CTRL+F3 to find the next instances of that.

So to reproduce:

Select a word and press CTRL+F3.

Then select nothing anymore and press CTRL+F. It fills the word last searched for with CTRL+F3 in the search box, and, scrolls the page even if you didn't want it to scroll because you want to search for a totally different word now starting from where your cursor was before it scrolled.

0
Comment actions Permalink

I was unable to reproduce the problem using the mentioned steps.

Will ask our QAs to try as well.

Denis

0
Comment actions Permalink

Sorry but we were unable to reproduce the problem locally.

Are you still experiencing it under 10.5.2? Have you tried to disable all third-party plugins?

Denis

0
Comment actions Permalink

Hello,

I don't think it's a plugin. Though possibly it's not version 10.5.2, but just 10.5. It says just 10.5 in the about.

I guess if it gets updated to 10.5.2 here some time then it'll be fixed.

Thanks a lot for the time, sorry for the time cost, I couldn't know this was so version dependent and was really affected by the jumping around of the search... I'm getting somewhat used to the behaviour now though so it's ok.

0
Comment actions Permalink

That's ok, thanks.

Denis

0

Please sign in to leave a comment.