possible to remove the 'out' folder from the Exclude list?

I know this is a total newbie question but I've been looking around for a bit and didn't see an answer. Whenever I try to remove 'out' from the Exclude list by going to Project Settings > Modules > Source and clicking the Exclude button it just ignores it. Is there some other (better) way to view my output folder or am I just missing something...?

5 comments
Comment actions Permalink

If you go to the "Paths" tab of "Modules" settings, you can specify whether to exclude the output folder or not if you really want to see it.

0
Comment actions Permalink

Hmm, I don't see a path's tab. When I right click the Module and go to Module Settings it just takes me to the Project Settings dialog with "Module" selected. From there I have 3 tabs: Sources, Dependencies and Flex Compiler Settings. I've tried clicking the Exclude button here to remove it but it doesn't do anything.

Here's a screenshot: http://i.imgur.com/G7eh8.png

0
Comment actions Permalink

You should have stated that you are talking about a Flex module, because different module types of course have different module settings.
But luckily the Flex module type has the same settings, just under the "Flex Compiler Settings -> Basic" tab.

0
Comment actions Permalink

oh sorry I should have specified.

changing the option in the Compiler settings did remove the folder from the Exclude list, but it still doesn't appear in the Project pane, which is pretty annoying :\

http://i.imgur.com/euTtp.png

0
Comment actions Permalink

For performance reasons it is not possible to unexclude 'out' folder (i.e. the folder that is specified at File | Project Structure dialog,  Project page, Project compiler output field). Unfortunately IDEA doesn't clearly explains this. Request to improve usability is: http://youtrack.jetbrains.net/issue/IDEA-73141

Workaround is to set specific output path at module level (in case of Flex module it is at Flex Compiler Settings tab, in case of Java module it is at Paths tab), and not to exclude it. If you want to use 'out' name then just rename project default to, say, 'out1', and then specify 'out' for each module.

0

Please sign in to leave a comment.