IDEA does not start claiming there is no Java system settings -- what is really needed?

Hello,

  I just installed IDEA (CE, 10.5.2), and when I try to run it I get such error:

No JDK found to run IDEA. Please validate either IDEA_JDK, JDK_HOME or JAVA_HOME environment variable points to valid JDK installation.

  The problem is, JAVA_HOME is set. It points to:
/usr/lib64/jvm/jre

  Just out of curiosity I also set IDEA_JDK and JDK_HOME -- no luck though, IDEA still does not start with the same error message.

   "java -version" tells me this:
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)


  So why I cannot run IDEA? Or -- what does IDEA really want?

  My system: openSUSE 11.4, 64-bit.

  Thank you in advance for your help.

Kind regards,

2 comments
Comment actions Permalink

A JRE is a Java Runtime Environment. A JDK is a Java Development Kit. A JDK is a JRE + development toolchain. Either you have a JRE but no JDK or IDEA simply doesn't know where your JDK is. Try typing 'which javac' from the command-line to see if you have the java compiler installed. If not you'll have to install the JDK.

0
Comment actions Permalink

Thank you very, very much. This solved my problem.

0

Please sign in to leave a comment.