Problems Running Flex Unit tests in 10.5

Whenever I try and run a unit test in IntelliJ for my AIR project I get a red popup saying:

Air application descriptor not found: /_blah-project-name-air-flexunit.xml

Where is it looking for this file, and why is it not being generated?

This is a project I created by hand in IDEA 9, and upgraded it to 10.5.  I'm running on Mac OS X 10.6, Flex 3.6, AIR 2.3.

Any ideas why this isn't working?

5 comments
Comment actions Permalink

Please check test output path at Project Structure | Modules | <your module> | Flex Compiler Settings tab.

0
Comment actions Permalink

Also make sure that 'Use IDE builder' is checked at the same tab and that 'Make before launch' is set for the run configuration.

0
Comment actions Permalink

Thanks.  I had the compiler output for the Flex facet as being compiled into another directory.  It was intentional that I did that, but turning that off and using the defaults worked for me.  Is this a known bug?  Should I file a bug for it?

Thanks for the quick response!

0
Comment actions Permalink

No, there are no known bugs in this area.
How many Flex facets per module do you have? Do you have the same output settings for all of them?
Please attach screenshot of Flex facet settings for the case when FlexUnit doesn't work.

0
Comment actions Permalink

I have two Flex facets on this module.  Both were compiling to another projects directory because they created their SWFs that loaded modules.  However, that has changed and they create SWC files so upon further inspection I believe letting them use the defaults will work just as well.

0

Please sign in to leave a comment.