CVS using :ssh: question

I'm trying to set a repository on a remote machine which
I would like to access using CVS+ssh, but I'm having some
problems and was wondering whether someone on the forum
can help:

Setup: Server running RHES3, Client running WinXP SP2, IDEA EAP Build 3429.
The server has an entry in /etc/xinetd.d/cvsservice, whic
sets up the server to use the usual port, 2401, and
specifies the repositories using the server-args parameter.
The last parameter on that line is pserver.


When I choose the :ssh: protocol to connect to the server,
everything works fine. However, when I'm trying to add
directories to the repository, I keep getting error
mentioning the Emptydir inside the CVSROOT directory,
but IDEA still marks the local CVS entries as if the
operation succeeded.

If I change the server xintetd settings so that the last
parameter on the server-args is ssh, I can successfully
add directories, but the user under which they get created
is root, not me. The group is still correct.

I know I could run an ssh client to maintain the tunnel,
and set the files to use localhost as the host containing
the repository, but I would like to avoid this.

Could anyone shed some light on how to set the CVS server,
SSH daemon/client up? I thought that I followed all the
necessary steps as outlined elsewhere on the net, but no
joy.

Cheers,

Bonny

1 comment
Comment actions Permalink

Please run IDEA with -Dcvs.print.output=true parameter and send me output
from IDEA console for these cases

"Bonny Rais" <bonnyr@optushome.com.au> wrote in message
news:7533122.1122885074037.JavaMail.javamailuser@localhost...

I'm trying to set a repository on a remote machine which
I would like to access using CVS+ssh, but I'm having some
problems and was wondering whether someone on the forum
can help:

>

Setup: Server running RHES3, Client running WinXP SP2, IDEA EAP Build
3429.
The server has an entry in /etc/xinetd.d/cvsservice, whic
sets up the server to use the usual port, 2401, and
specifies the repositories using the server-args parameter.
The last parameter on that line is pserver.

>
>

When I choose the :ssh: protocol to connect to the server,
everything works fine. However, when I'm trying to add
directories to the repository, I keep getting error
mentioning the Emptydir inside the CVSROOT directory,
but IDEA still marks the local CVS entries as if the
operation succeeded.

>

If I change the server xintetd settings so that the last
parameter on the server-args is ssh, I can successfully
add directories, but the user under which they get created
is root, not me. The group is still correct.

>

I know I could run an ssh client to maintain the tunnel,
and set the files to use localhost as the host containing
the repository, but I would like to avoid this.

>

Could anyone shed some light on how to set the CVS server,
SSH daemon/client up? I thought that I followed all the
necessary steps as outlined elsewhere on the net, but no
joy.

>

Cheers,

>

Bonny



0

Please sign in to leave a comment.