Cannot run android application - please help

I just started to develop Android application.
I installed Android sdk and I tried to use IntelliJ Idea.
I created a project (hello world) and it worked fine.
The day after it did not work.
I get this message:
Cannot obtain path to VM executable for JDK Android 3.2 platform.
I re installed every thing and still get this message.
Any idea?
Thanks,
Raffi

2 comments
Comment actions Permalink

I just had the same very frustrating problem.

I was able to solve it like this:
File Menu -> Project Structure
Click on 'SDKs'
Click on your Android SDK.  You may notice that the Java SDK drop-down is empty.
Click the little '+' symbol at the top of the second column (above where your Android SDK is listed)
The '+' should give you a little drop-down menu.  Choose JSDK from that menu.  I had to do it twice for some reason.
Now find your JDK directory.
That should be it!  Check your Android SDK settings to make sure the Java SDK is listed.

I noticed that I have to do this every time I open the Project Structure dialog.  It's very annoying.

Now I just need to figure out how to launch a virtual device. :(

0
Comment actions Permalink

Thanks Joe.
It was too frstrating for me, I guess.
I uninstalled Idea and installed Eclipse and everything works fine...
Raffi

0

Please sign in to leave a comment.