problem setting an artifactory repository

hello
i'm using intellij 10.5.1 and i'm trying to setup an artifactory repository
currently i have artifactory 2.3.4 running at http://localhost:8081/artifactory. in intellij project settings -> maven -> repositories i added a new repository with this address. when trying to test it, i'm getting a No repositories found error.
looking at the intellij log, this appears to be the problem:

2011-08-05 11:08:34,935 [ 314776]   INFO -      #org.jetbrains.idea.maven - com.google.gson.JsonParseException: Failed parsing JSON source: java.io.InputStreamReader@c1dece to Json
java.io.IOException: com.google.gson.JsonParseException: Failed parsing JSON source: java.io.InputStreamReader@c1dece to Json
 at org.jetbrains.idea.maven.services.artifactory.ArtifactoryRepositoryService.getRepositories(ArtifactoryRepositoryService.java:56)
 at org.jetbrains.idea.maven.services.MavenRepositoryServicesManager.getRepositories(MavenRepositoryServicesManager.java:102)
 at org.jetbrains.idea.maven.utils.RepositoryAttachHandler$3.run(RepositoryAttachHandler.java:252)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$TaskRunnable.run(ProgressManagerImpl.java:464)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:181)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:209)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:172)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$6.run(ProgressManagerImpl.java:340)
 at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:375)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:662)
 at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:130)
Caused by: com.google.gson.JsonParseException: Failed parsing JSON source: java.io.InputStreamReader@c1dece to Json
 at com.google.gson.JsonParser.parse(JsonParser.java:55)
 at com.google.gson.Gson.fromJson(Gson.java:376)
 at com.google.gson.Gson.fromJson(Gson.java:352)
 at org.jetbrains.idea.maven.services.artifactory.ArtifactoryRepositoryService.getRepositories(ArtifactoryRepositoryService.java:48)
 ... 15 more
Caused by: com.google.gson.TokenMgrError: Lexical error at line 1, column 1.  Encountered: "<" (60), after : ""
 at com.google.gson.JsonParserJavaccTokenManager.getNextToken(JsonParserJavaccTokenManager.java:1194)
 at com.google.gson.JsonParserJavacc.jj_ntk(JsonParserJavacc.java:588)
 at com.google.gson.JsonParserJavacc.parse(JsonParserJavacc.java:9)
 at com.google.gson.JsonParser.parse(JsonParser.java:53)
 ... 18 more




i tried to export a settings.xml file from artifactory and set it as the maven settings file in intellij, but this does'nt seem to help

thanks

Please sign in to leave a comment.