Auto-complete annoyance in 10.5.1

Anybody else getting annoyances like this with 10.5?

public enum Bob {
     RED, GREEN, BLUE;
     ..now type: public<space>static<space>final<space>
}

What happens in my IDE is final above gets replaced by Finalizable (ie. public static Finalizable).. thats the Batik class org.apache.xmlgraphics.util.io.Finalizable (which it automatically adds an import for - it's in my classpath). Gussing any class/interface starting with final would also have similar effect, so now I have to type public<space>static<space>final<esc><space> ?

- Richard

PS Related to http://devnet.jetbrains.net/message/5311802 and possibly some of @mikaelgrev recent IDEA grumbles ..?

4 comments
Comment actions Permalink

Just a follow up on related behaviour I'm not sure I've seen before. If I comment out the rouge Finalizable line IDEA automatically removes the import too? since when did IDEA automatically optimize my imports? Not convinced thats always going to be helpful.

0
Comment actions Permalink

Hello Richard,

You can find the "Optimize impors on the fly" option in the settings. Feel
free to turn it off if you don't consider it helpful.

Just a follow up on related behaviour I'm not sure I've seen before.
If I comment out the rouge Finalizable line IDEA automatically removes
the import too? since when did IDEA automatically optimize my imports?
Not convinced thats always going to be helpful.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks, just don't fancy having to manually re-add (alt-enter) those imports when commenting in/out chunks just to run my own tests etc.. Its going to be hit & miss when I want it or don't doubtful I'll be able to think ahead enough to toggle the option on&off beforehand so just setting it off now might be safest option.

First issue was the worst, is that reproducible?

0
Comment actions Permalink

I agree with you - the code completion in 10.5 is a mess.

Tom

0

Please sign in to leave a comment.