JB: OpenAPI depends on idea.jar classes in latest build

Hi, a few classes, like PsiFileBase, depend on classes that aren't in
OpenAPI. I thought a lot of bad things had happened, but then I realized
I just need to add idea.jar to classpath. Anyway I thought you should
know that this happened.

1 comment
Comment actions Permalink

Keith Lea wrote:

Hi, a few classes, like PsiFileBase, depend on classes that aren't in
OpenAPI. I thought a lot of bad things had happened, but then I realized
I just need to add idea.jar to classpath. Anyway I thought you should
know that this happened.

Also you might want to know that I get this when extending
AstWrapperPsiElement:

/Users/keithkml/Development/Projects/genproto/src/net/kano/genproto/lex/ProtoFloatLiteral.java
Warning: Warning: line
(39)getCopyableUserData(com.intellij.openapi.util.Key) in
com.intellij.extapi.psi.ASTWrapperPsiElement implements
getCopyableUserData(com.intellij.openapi.util.Key]]>) in
com.intellij.psi.PsiElement; return type requires unchecked conversion
found : java.lang.Object
required: T

0

Please sign in to leave a comment.