Unable to debug AIR Android mobile app - breakpoints not caught

Hi,

I've unable to fully debug my Android AIR mobile app using IntelliJ 10.5.1

I can successfully can set breakpoints which are caught in the ViewNavigatorApplication.mxml file.  However none of the breakpoints set in any of the View's are being caught (e.g. firstView and all View's have red X's on my breakpoints)

App + code is being executed, as I've put trace statements in View code and they are correctly outputting to console and app is running.

For the same project in FlashBuilder, View's can successfully be debugged in FlashBuilder with breakpoint's being caught as expected.


I've also tried creating a separate smaller, sample app and can successfully set breakpoint's that are caught in View's for this SmallSample AIR Android app



One thing I've noticed when comparing FlashBuilder with IntelliJ...FlashBuilder produced swf in bin-debug is much larger than IntelliJ's.  FlashBuilder = 3995kb and IntelliJ's = 1827kb

I'm using:
- IntelliJ 10.5.1
- Win XP pro
- Flashbuilder 4.5.1 premium
- AIR mobile 4.5.1


Out of curiosity, does anyone know how to log to console the adl.exe command coming from FlashBuilder?

3 comments
Comment actions Permalink

Breakpoint with cross means that Adobe's fdb tool said that there's no executable code at this line. So this is probably a bug in fdb which is not workarounded at IDEA's side. FB doesn't use fdb so they don't have this bug. Do you have inline item renderers in your Views? Probably this is a known bug: http://youtrack.jetbrains.net/issue/IDEA-57546

0
Comment actions Permalink

thanks for the feedback!  inline renderer is the problem...moving to codebehind fixes it.

shame on adobe for:
1.  closing the ticket!
2.  exposing one tool(adl) for open source and another for themselves

0
Comment actions Permalink

By the way we have workarounded problem with breakpoints and item renderers. Get the fix here.

0

Please sign in to leave a comment.