Breakpoints marked invalid

Build 3408 marks all my breakpoints as invalid when they are reached.
It says: Source code changed.
But I didn't change anything.
Can anybody give me a reason for this beahviour ?

mfg
Carsten

2 comments
Comment actions Permalink

If you are debugging a remote application, there is a possibility that classes loaded into the debuggee VM do not correspond to the
sources (some old jars in classpath for example).

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Carsten Schäfer" <ca_schaefer@gmx.de> wrote in message news:dbidov$7e5$1@is.intellij.net...

Build 3408 marks all my breakpoints as invalid when they are reached.
It says: Source code changed.
But I didn't change anything.
Can anybody give me a reason for this beahviour ?

>

mfg
Carsten



0
Comment actions Permalink

Eugene Zhuravlev (JetBrains) schrieb:

If you are debugging a remote application, there is a possibility that classes loaded into the debuggee VM do not correspond to the
sources (some old jars in classpath for example).

No, I'm not remote debugging.
But I have two modules defined.
One main module with all of my sources and one other module without any
content root.
They both have the same classpath, just one directory is different. In
this dir are the property files (no src or classes). Because every class
i want to run/debug needs different propertys and the only way to use
different classpath in the run/debug dialog is via modules.

mfg
Carsten

0

Please sign in to leave a comment.