I'm getthing this inspection lots in my code now, where I've got something like this:
final BasicAuthInfo userAuthInfo = new BasicAuthInfo(username, password);
Even though it really is redundent, I view this as good coding practice; It's slightly documentory because of the variable name, and its easier to set a breakpoint when debugging.
The compiler should optimize this anyone (same bytecode output). So does this inspection really deserve to be on by default?