Classes in flash package not available in Flash/Flex project


I have a problem with a Flash/Flex project in IntelliJ. I have created both Flex (4.5) and Adobe Air SDKs pointing to an apropriate directory (about 20 swc files are shown in classpath settings). But I have problem that IDEA says on imports of flash.* the package does not exist. Even classes such as String, Boolean are not known. When rurring the sample application (generated on a new project creatin) it compiles and runs OK. However I get a lot of errors highlighted in the editor and no advanced code completition features.

Does anybody have the same problem or knows the solution? Thanks.


Comment actions Permalink

Hello Vaclav,

Please ensure your SDK is specified in module settings as Module SDK (File | Project structure | Modules | your module | Dependencies tab). If it's OK, please try to invalidate caches (File | Invalidate Caches).


Comment actions Permalink


It seems you have the same problem as me (see the issue I reported : I assume you're running Windows 7, right ?

I tried different things :
- invalidating the cache
- swithcing to open source version of flex sdk
- running as Administrator

but i still get the same indexing error in the log files. If you found a workaround, please tell me.



Please sign in to leave a comment.