Latest IdeaVIM plugin changes my keymap

I am running Intellij 10.0.3 and every since I updated the IdeaVIM plugin to the latest version last week every time I open a new project my chosen keymap gets changed to VIM rather than my preferred one of Mac OS X 10.5+.

Is there a way to stop IdeaVIM from changing my chosen keymap? I don't see any configs available for IdeaVIM.

10 comments
Comment actions Permalink

Hello Michael,

Sorry for such a delay in answer, I had my hands full. VIM keymap is nescessary for ideavim plugin correct work. In case if you still want to use MacOSX keymap, please use Tools | Reconfigure VIM Keymap menu action. This allows you to choose base keymap for VIM's one. In the next plugin version we'll improve the default behavior.

Regards,
Oleg

0
Comment actions Permalink

Thanks for the tip about the option in the Tool menu.

Out of curiosity what doesn't work when you don't use the VIM keymap? Everything seems to work fine for me. On occasion the cursor does jump to random places on me when I delete a line with "dd" and then get an exception like this (truncated stack strace). Is this a product of not using the VIM keymap? Changing keymaps at this point would be damn near impossible. I have been working with the Mac keymap for quite some time and have too much muscle memory built up for my commonly used shortcuts.

Wrong offset: 5918 textLength: 4321: Wrong offset: 5918 textLength: 4321
java.lang.IndexOutOfBoundsException: Wrong offset: 5918 textLength: 4321
 at com.intellij.openapi.editor.impl.EditorImpl.calcLogicalLineNumber(EditorImpl.java:3151)
 at com.intellij.openapi.editor.impl.EditorImpl.offsetToLogicalPosition(EditorImpl.java:1083)
 at com.intellij.openapi.editor.impl.SoftWrapModelImpl.offsetToLogicalPosition(SoftWrapModelImpl.java:349)
 at com.intellij.openapi.editor.impl.EditorImpl.offsetToLogicalPosition(EditorImpl.java:1081)
 at com.intellij.openapi.editor.impl.EditorImpl.offsetToLogicalPosition(EditorImpl.java:1074)
 at com.maddyhome.idea.vim.helper.EditorHelper.getLineEndForOffset(EditorHelper.java:528)
 at com.maddyhome.idea.vim.group.MotionGroup.updateSelection(MotionGroup.java:1701)
 at com.maddyhome.idea.vim.group.MotionGroup.moveCaret(MotionGroup.java:1267)
 at com.maddyhome.idea.vim.group.MotionGroup.moveCaretToView(MotionGroup.java:999)
 at com.maddyhome.idea.vim.group.MotionGroup$EditorScrollHandler.visibleAreaChanged(MotionGroup.java:1828)
 at com.intellij.openapi.editor.impl.ScrollingModelImpl$1.stateChanged(ScrollingModelImpl.java:75)
 at javax.swing.JViewport.fireStateChanged(JViewport.java:1384)
 at javax.swing.JViewport.setViewPosition(JViewport.java:1140)
 at javax.swing.plaf.basic.BasicScrollPaneUI$Handler.vsbStateChanged(BasicScroll

0
Comment actions Permalink

This one for example: http://youtrack.jetbrains.net/issue/VIM-2
I guess that this is not connected directly to the keymap, however could you please file an issue with detailed description in order to reproduce and fix it?

Regards,
Oleg

0
Comment actions Permalink

I have wanted to report the errors I see; however, the problem is I can't recreate them at will. The exceptions happen on occasion when I am typing and using some vim commands (I am a pretty basic VIM person, h j k l for navigation, some dd yy p and cl cw is about all I do). So I am not sure if it would be beneficial to report them when all I could say is "this exception occured when I was typing" :-)

Should I report them anyway?

Also, I notice the the Submit button on the IDE Fatal Errors dialog is never enabled so I can't report them from there (see screenshot). Is that by design?

Screen shot 2011-04-20 at 9.27.37 AM.PNG

0
Comment actions Permalink


I have wanted to report the errors I see; however, the problem is I can't recreate them at will. The exceptions happen on occasion when I am typing and using some vim commands (I am a pretty basic VIM person, h j k l for navigation, some dd yy p and cl cw is about all I do). So I am not sure if it would be beneficial to report them when all I could say is "this exception occured when I was typing" :-)

Should I report them anyway?

Also, I notice the the Submit button on the IDE Fatal Errors dialog is never enabled so I can't report them from there (see screenshot). Is that by design?

Unfortunally this is disabled by design for now, so please report any problems manually.

Regards,
Oleg

0
Comment actions Permalink

Is there a way to rollback to an earlier IdeaVIM version? The switching of the keymap when I open a new project is beyond annoying. It is counter-productive. Please don't just switch a user's keymap on them for no apparent reason. The Mac OS X 10.5+ keymap works just fine for me with IdeaVIM.

The Tools->Reconfigure Keymap option doesn't appear to do anything. It doesn't switch my keymap back nor does it keep IdeaVIM from switching to the VIM keymap.

0
Comment actions Permalink

You have to restart the IDE in order to get changes in keymap applied. In the next plugin version we'll ask user if he really wants to use vim keymap.
Excpect new version coming soon.

Regards,
Oleg

0
Comment actions Permalink

Oleg,

I'm having a problem, and I'm not sure if it's related. When I choose the "Mac OSX" IdeaVIM keymap (*not* the "Mac OSX 10.5+") a lot of my favorite key bindings don't work.

For example:
apple-n : Go to class (nothing happens)
apple-b : Go to definition (nothing happens)


Is there any way to downgrade to a previous version of the IdeaVIM plugin? This issue has actually kept me from using Intellij 10+ (I've reverted to using Intellij 9.x).

Thanks,
Ed

0
Comment actions Permalink

Hmmm... the following steps seem to have resolved the issue:

1) Unistall IdeaVIM
2) Set my Intellij keymap to "Mac OSX"
3) Re-install IdeaVIM
4) Set my IdeaVIM keymap to "Mac OSX"

So I'm up and running.

Thanks for IdeaVIM!

-ed

0
Comment actions Permalink

Yep, this is a possilble solution, however in the latest available ideavim version the preferred solution is via Tools | Reconfigure VIM Keymap.

Thanks for IdeaVIM!

Develop with pleasure!

Regards,
Oleg

0

Please sign in to leave a comment.