Import a Library into Android Project

For some reason I cannot import the google Analytics SDK into my project.

http://code.google.com/mobile/analytics/docs/android/#gettingStarted

I've tried putting it in my libs directory, no change.

I've tried adding it as a dependency

  • Single Entry - doesn't appear  when I use the browse add a single entry
  • Library
    • Attach Classes - doesn't show the jar
    • Added as library directory, doesn't seem to work
    • Didn't try Attach Sources - as I don't have the sources, just the Jar


What am I doing wrong?   I have joda-time.jar added as a dependecny and its working fine, so I don't know why this one isn't.

3 comments
Comment actions Permalink

Anyone?   This is a fairly popular Google library, I can't be the only one having issues.

0
Comment actions Permalink

What version of IDEA do you use? I haven't got any problems with adding this jar by both ways. If you add "library" dependency, you should to use "Attach jar directories" in your case.

0
Comment actions Permalink

AHHHHH, I'm not sure but sure as you reply and I check its there now.

I have restarted and reopened the project a few times so I'm not sure.  My users call it 'Support Team' prescence.

Thanks.

0

Please sign in to leave a comment.