Unable to debug in IDEA 4.5 with JRE 1.4.2_08

Hi,

As a beginner to IntelliJ I hope someone can help me out here. I have a simple program that I would like to debug. As I attempt this I get the following error:
-


C:\java\j2sdk1.4.2_08\bin\java -Xdebug -Xrunjdwp:transport=dt_socket,address=marcus-dator:2016,suspend=y,server=n -Dfile.encoding=windows-1252 -classpath "C:\java\j2sdk1.4.2_08\jre\lib\charsets.jar;C:\java\j2sdk1.4.2_08\jre\lib\jce.jar;C:\java\j2sdk1.4.2_08\jre\lib\jsse.jar;C:\java\j2sdk1.4.2_08\jre\lib\plugin.jar;C:\java\j2sdk1.4.2_08\jre\lib\rt.jar;C:\java\j2sdk1.4.2_08\jre\lib\sunrsasign.jar;C:\java\j2sdk1.4.2_08\jre\lib\ext\dnsns.jar;C:\java\j2sdk1.4.2_08\jre\lib\ext\ldapsec.jar;C:\java\j2sdk1.4.2_08\jre\lib\ext\localedata.jar;C:\java\j2sdk1.4.2_08\jre\lib\ext\sunjce_provider.jar;C:\Documents and Settings\Marcus\IdeaProjects\Test\classes;C:\Program\IntelliJ-IDEA-4.5\lib\idea_rt.jar" Testing.RunTestCode
err:: No such file or directory
FATAL ERROR in native method: No transports initialized
Error in connect() call!
Socket transport failed to init.
Transport dt_socket failed to initialize, rc = -1.

Process finished with exit code 1
-



I have re-installed both the JRE and IntelliJ without any luck.

Thanks in advance,
Marcus

6 comments
Comment actions Permalink


Seems like a "spaces in path" problem. Try installing IDEA in a path without
spaces - I usually use c:\java\idea.


0
Comment actions Permalink

What kind of app are you trying to debug? is it a "stand alone" VM that you are trying to remotely debug? if so, you will need to add the "-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005" parameters that are shown in the debug configurations popup to the start up line for your remote application.

0
Comment actions Permalink

Carlos,

I changed the project directory to not hold spaces and got a bit further. I now get the following pop-up error window:
-


Cannot debug application

Check your run/debug configuration. Failed to establish connection to the target VM at '127.0.0.1:1717' using socket transport
-



Ralph,

I also tried adding the parameters (in VM parameters in the Run/Debug configurations) but get a similar error window. I tried setting the address to both 5005 and 127.0.0.1:5005 with no luck.

For some reason the address does not get affected from the settings. The value ends up being address=marcus-dator:]]> ("marcus-dator" is the name of my computer.) The 4-digit value is the same that appears in the error window after "127.0.0.1:".

To clarify, I've created a single module application using Java Core classes. Nothing fancy at all. I'm not sure what you mean by remotely.

/Marcus

0
Comment actions Permalink

Are you trying to run an application under the IDE in debug mode, or are you tryiong to connect to a remote VM to debug it? The error message seems to indicat that you are trying to debug a remote VM, but your comments are leading me to believe that you want to run the application in the IDE in debug mode.

0
Comment actions Permalink

I want to run the application in the IDE in debug mode.

0
Comment actions Permalink

Marcus <no_mail@jetbrains.com> wrote:

FATAL ERROR in native method: No transports initialized
Error in connect() call!
Socket transport failed to init.
Transport dt_socket failed to initialize, rc = -1.


In my setup, this usually is caused by DNS problems. Make sure the
hostname of your machine resolves properly.

Best,

Dirk Dittert

0

Please sign in to leave a comment.