10.5 errors joint java groovy compilation

I've seen a few topics around this in the discussion group but unfortunately the suggested solutions haven't worked for us.  Most of the solutions seem to be for pre - 10.5 versions.  We have a multi module project that's purely Java.  I'd like to introduce groovy for one of the modules since the module is a simulator and could use a dose of rapid development.

I've been able to successfully create a very bare bones single project/module with 1 java class and 1 groovy class and get the joint compilation to work successfully.  However; in our project that has 4 modules I get errors about "cannot find symbol" when I try to compile the module, after introducing a groovy class.  The usage is the exact same as the simple project.  I've introduced a new Main.java and a SimpleEcho.groovy.  When I try to build the project or the module I get the errors.
Here's what I've done:

  • Created a new src/main/groovy directory
  • Created a very simple SimpleEcho.groovy file
  • Referenced SimpleEcho.groovy from Main.java class located in src/main/java

I've tried clearing caches, re-creating the IntelliJ project via Maven idea:idea, etc... and have had no luck.  


.CompileError.png

I'm using IntelliJ 10.5 Ultimate, Groovy 1.8, Java 6.  At this point I'm blocked from using


Image editing courtesy of Pixlr.com (I'm in no way involved with pixlr but I thought the tool was so useful it deserved a plug)

Please sign in to leave a comment.