Mac: avoid Ctrl+Click opens the context menu

Hi,

To not need to learn my hands new keycombinations, I've mapped
Ctrl-Click to Goto Declaration functionality. Unfortunately it opens the
context menu, too. Is there a choice to not open the context menu?

Tom

8 comments
Comment actions Permalink

Tom,

>

To not need to learn my hands new keycombinations, I've mapped
Ctrl-Click to Goto Declaration functionality. Unfortunately it opens
the context menu, too. Is there a choice to not open the context menu?

>



I know I shouldn't tell you, but here it is:
Preferences.Keyboard & Mouse.Keyboard.Modifiers Keys.Control Key: no
action.



Please, don't ask me how to replace the blue apple by a window.


Alain

0
Comment actions Permalink

I know I shouldn't tell you, but here it is:
Preferences.Keyboard & Mouse.Keyboard.Modifiers Keys.Control Key: no
action.


Do I understand it correctly: choosing "no action" deactivates the ctrl
key at all? This is no option for me, because then quite no accelerator
works for me in IDEA. My hands don't care, whether all applications on
Mac OS use the 88 key, they are trained for the Ctrl key.

BTW, it could have been possible, that there is a bug in IDEA, which
causes too actions (Goto Declaration and showing the context menu) to be
performed in this particular case.

Sorry for bothering you again, but when you choose IDEA's Mac OS X
keyboard mapping, Run|Run is mapped to Shift-F10, which does not work in
my situation, because it shows all windows on screen. Is Mac OS X or an
invisible application steeling Shift-F10? Maybe the default mapping
should NOT use Shift-F10?

Tom

0
Comment actions Permalink

Tom

>> Preferences.Keyboard & Mouse.Keyboard.Modifiers Keys.Control Key: no
>> action.
>
>

Do I understand it correctly: choosing "no action" deactivates the
ctrl key at all?



It deactivates MacOS aliasing Ctrl+Left-click to Right-click.
I thought you were willing to make that sacrifice, because you are using
a multi-button mouse.

This is no option for me, because then quite no accelerator works for
me in IDEA. My hands don't care, whether all applications on Mac OS
use the 88 key, they are trained for the Ctrl key.



Many of the Windows Ctrlkey shortcuts become Commandkey on MacOS.

//when you choose IDEA's Mac OS X keyboard mapping, Run|Run is mapped
to Shift-F10, which does not work in my situation, because it shows
all windows on screen.


It works for me.

Is Mac OS X or an invisible application steeling Shift-F10?


I suspect that's the case.
I have this kind problem with Shift-Command-F (Search in Path), that's
captured by Launchbar.app


Alain

0
Comment actions Permalink

You can regain your F9-12 by changing the expose key mappings in system prefs.

ctrl-click is universally recognised as a right click in OSX, so remapping it is generally not such a good idea. Why not go for alt or apple click instead?

0
Comment actions Permalink


>You can regain your F9-12 by changing the expose key mappings in system prefs.
>

>


On my Powerbook, I unmapped all the default Exposé keys, and just
remapped "Exposé.All windows" to the special 'fn' key.
On an iMac where I use a 5-button mouse, I placed "Exposé.All windows"
just under my thumb.

You have to find your way, but don't look back too much to Windows. If
you fiddle a lot while learning, be ready to reinstall MacOS in a few
months => keep track of your customizations.


Alain

0
Comment actions Permalink

>> Do I understand it correctly: choosing "no action" deactivates the
>> ctrl key at all?


It deactivates MacOS aliasing Ctrl+Left-click to Right-click.
I thought you were willing to make that sacrifice, because you are using
a multi-button mouse.


No, it removes the Ctrl-key at all (as it would not be there).

Many of the Windows Ctrlkey shortcuts become Commandkey on MacOS.


I know, but the Command key unfortunately is where the Alt key is on my
Windows keyboard. Hence I took IDEA's windows keymapping and replaced
all Alt combinations (I use) with Command combinations.

>> //when you choose IDEA's Mac OS X keyboard mapping, Run|Run is mapped
>> to Shift-F10, which does not work in my situation, because it shows
>> all windows on screen.


It works for me.

>> Is Mac OS X or an invisible application steeling Shift-F10?


I suspect that's the case.
I have this kind problem with Shift-Command-F (Search in Path), that's
captured by Launchbar.app


It looks like Exposé steels the key although the keys are deactivated in
Keyboard Shortcuts...

Tom

0
Comment actions Permalink

You can regain your F9-12 by changing the expose key mappings in system prefs.


I've tried. It works for F9-F11, but not for Shift-F9 to Shift-F11.

Why not go for alt or apple click instead?


Because I work 95% of the time on Windows and teaching the fingers new
key-combinations is a very hard task.

Tom

0
Comment actions Permalink

Just for the records:

>> You can regain your F9-12 by changing the expose key mappings in
>> system prefs.


I've tried. It works for F9-F11, but not for Shift-F9 to Shift-F11.


There is a bug in Exposé, which causes to eat Shift-F9..Shift-F11 even
if no keys are defined in the System Preferences. Changing the keys
there to something else releases the Shift-F9..Shift-F11 shortcuts for
other applications like IDEA.

Tom

0

Please sign in to leave a comment.