Applecation server integration

Hi All,
     I don't know why I am getting an issue while running app server from intellij. But i can run app server from different project. What might be the problem ? Any help is appriciated . I am new to this ide.

6 comments
Comment actions Permalink

Hello Niraj,

Please describe in more detail which application server you're trying to
run and which exactly problem you see.

I don't know why I am getting an issue while running app server
from intellij. But i can run app server from different project. What
might be the problem ? Any help is appriciated . I am new to this ide.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry,
     I am using JBoss eap 5.1.0 and IntelliJ 10.03, the license is purchased by client. I have integrated JBoss 5.1.0 eap with IntelliJ for some local hello world project and its running fine. But I am doing the same for my project there my whole team is getting the same issue. Please update this. Is the problem related with maven build or project.iml file , because it was running fine before with the project for whole team. After some changes with the maven build its getting this issue

cmd /c D:\Softwares\jboss-eap-5.1\jboss-as\bin\run.bat -c default
Calling D:\Softwares\jboss-eap-5.1\jboss-as\bin\run.conf.bat
Files\JetBrains\IntelliJ was unexpected at this time.
Disconnected from server


But it can be run from command prompt.

Please help me .


Thanks

Niraj

0
Comment actions Permalink

Hello,

It looks like an environment variable contains a path with some space characters, and JBoss doesn't like it.

As the first step, you can do the following:
- remove/comment out the first line "@echo off" in the D:\Softwares\jboss-eap-5.1\jboss-as\bin\run.bat
- insert as the first line of the D:\Softwares\jboss-eap-5.1\jboss-as\bin\run.conf.bat" the following 1 line (just to display the actual variables set)

SET

- run your configuration
- give us the output produced

Regards,
Michael

0
Comment actions Permalink

You are absolutely right, that its a problem with environment but you can set it from IDE itself.

I am giving the settings in an image.Server_Settings_JBoss.JPG
Please see the high-lighted portion.

Thanks,
Niraj

0
Comment actions Permalink

Hello,

I can see you've added '-b localhost' manually to the server startup command line.
But it's not clear :
- have you fixed your environment in this way and have now JBoss working?
- or this is your initial configuration and the issue is still reproduced?

I've tried to add '-b localhost' to my JBoss EAP 5.1.0 runtime configuration, but the issue is still can't be reproduced.
And I don't believe adding '-b localhost' may somehow influence the situation.

But I have to admit that there are some other observed problems with the spaced names and JBoss (http://devnet.jetbrains.net/message/5303552#5303552), so there is probably a bug here.
While I am checking it right now, I would recommend to temporarily reinstall both server and IDEA into the fodlers without spaces.

Regards,
Michael

0
Comment actions Permalink

Hi all,
     I have solved the problem by adding -b localhost to run command manually. And it works fine.

Thanks,
Niraj

0

Please sign in to leave a comment.