Can't compile Flex 4.5 module

Adobe recently released Flex 4.5, and I'm giving it a try.  However, IntelliJ is unable to invoke the compiler for a flex module once I update my settings from an earlier Flex SDK version.

Here's the context, and what I've learned so far:

We use Maven as our primary build tool, and I updated the dependency versions in our pom.xml files for com.adobe.flex compiler from 4.1.0.16248 to 4.5.0.18623.  I can compile just fine using the Maven compile task and org.sonotype.flexmojos flexmojos-maven-plugin.

Under Flex 4.1, the flex compiler creates a compiler configuration report, index-config-report.xml, with all the compile settings. When you click the 'Make Project' button in IntelliJ, it invokes the flex compiler using that index-config-report.xml file, and everything compiles nicely.  When I move to Flex 4.5, the flex compiler produces index-configs.xml instead, which IntelliJ tries to use the same way.

However, and this appears to be the key: index-config-report.xml has the fileSpec of your main flex class at the end of the file (Main.mxml for our project), index-configs.xml does not. So when IntelliJ invokes the flex compiler, the compiler complains that no target file is specified.  It just doesn't know where to start compiling. "Error: [flex-module (Flex)] a target file must be specified"

I've tried this with IntelliJ 10.0.3 and with the brand new 10.5, same problem in both cases.  I've also tried changing the IntelliJ Flex Compiler settings, using 'Built-in compiler shell', 'Flex Compiler Shell (fcsh)', and 'Mxmlc/compc' options, no difference in behavior.

I think this is just a version incompatability bug, but I thought I'd check to see if I'm missing a step somewhere.  Any ideas?

Mike

2 comments
Comment actions Permalink

Hi Michael!
The problem is not in changing SDK, it is in changing Flexmojos plugin version. With Flexmojos 3.x ..-config-report.xml files are generated, whereas with Flexmojos 4 - ...-configs.xml. These -configs.xml files are usually not complete and incorrect. Relative issue and workaround is here: http://youtrack.jetbrains.net/issue/IDEA-67993#comment=27-211886

0
Comment actions Permalink

Thanks Alexander. The idea-flexmojo plugin you pointed me to now creates a config file that IntelliJ can use, so I'm back to compiling at will.

0

Please sign in to leave a comment.