XSD dependent resource search look at local resources?

I have an XSD file which has this line:

    <import namespace="http://www.opengis.net/gml" schemaLocation="http://schemas.opengis.net/gml/3.1.1/base/gml.xsd"/>

Since gml.xsd isn't recognized, I get the  "Fetch External Resource" prompt.  When I select it, the progress bar goes about 95% of the way, pauses for a few seconds, and then this error pops up:
Error-Resource.png
Sure enough, that URL to rdf.xsd file cannot be resolved.  So I found an updated one that is close enough (from 2000/07), downloaded it, and manually added it to resources under the older URL (1999/02):

Resources-Dialog.png

If I include a direct reference to that "1999/02" URL in an XML file, like this:

<rdf:RDF xmlns="http://www.w3.org/1999/02/rdf.xsd" ...>

Intellij resolves it fine using the local resource.  But I still get the same error when I try to fetch the original gml.xsd resource.  Is this a bug or am I missing some step?

Build: 10.0.2 (build #103.72)

adTHANKSvance,

e

Please sign in to leave a comment.