idea 3326 and jdk 1.6

I run idea 3290 using 1.6 and everything is fine. When I tried to run idea3326 using 1.6, I am getting the following error. Is this expected or am I doing something worng (other than running "not supported" jdk)?

thanks
vinay

FATAL ERROR: JVMPI, an experimental interface, is no longer supported.
Please use the supported interface: the JVM Tool Interface (JVM TI).
For information on temporary workarounds contact: jvmpi_eol@sun.com
YourKit Java Profiler 4.0.3 cannot start: JVM does not support JVMPI_VERSION_1_1
Error occurred during initialization of VM

1 comment
Comment actions Permalink

IDEA uses YourKit's JVMPI interface to profiling. This was deprecated in
Java 5, and is no longer present in Java 6. You can remove the YourKit line
from the IDEA VM options file in idea\bin

Anyway I don't think it will work because no.jdk.check was removed and I
read that it still hasn't been put back in latest build.

I run idea 3290 using 1.6 and everything is fine. When I tried to run
idea3326 using 1.6, I am getting the following error. Is this expected
or am I doing something worng (other than running "not supported"
jdk)?

thanks
vinay
FATAL ERROR: JVMPI, an experimental interface, is no longer supported.
Please use the supported interface: the JVM Tool Interface (JVM TI).
For information on temporary workarounds contact: jvmpi_eol@sun.com
YourKit Java Profiler 4.0.3 cannot start: JVM does not support
JVMPI_VERSION_1_1
Error occurred during initialization of VM




0

Please sign in to leave a comment.