Cannot resolve property key - Localization issue

We use the XML file structure to store our localized strings for our Java/HTML application. We also use the Wicket framework, although as far as I can tell this is not the source of the problem.
http://apache-wicket.1842946.n4.nabble.com/Wicket-IntelliJ-and-xml-resource-bundles-td2132681.html

The problem is that IDEA insists on flagging every reference to an XML based localization key as an error - I'm assuming because it can't find the .properties file.

How can i turn off this warning? I see a similar issue/solution for JSP files, but our references are in HTML files. Here is an extract:

    <wicket:message key="releaseDate"></wicket:message>
    <wicket:message key="version"></wicket:message>

It is annoying to have a file full of flagged errors when nothing is wrong.

Thanks!
Geoff

1 comment
Comment actions Permalink

Currently there's no way to do it.
Feel free to vote for http://youtrack.jetbrains.net/issue/IDEA-53318.

"Geoff Hayman" <no_reply@jetbrains.com> сообщил(а) в новостях
следующее:5075861.1041299613458507.JavaMail.devnet@domU-12-31-39-18-36-57.compute-1.internal...

We use the XML file structure to store our localized strings for our
Java/HTML application. We also use the Wicket framework, although as far
as I can tell this is not the source of the problem.
http://apache-wicket.1842946.n4.nabble.com/Wicket-IntelliJ-and-xml-resource-bundles-td2132681.html

>

The problem is that IDEA insists on flagging every reference to an XML
based localization key as an error - I'm assuming because it can't find
the .properties file.

>

How can i turn off this warning? I see a similar issue/solution for JSP
files, but our references are in HTML files. Here is an extract:

>

    <wicket:message key="releaseDate"></wicket:message>
    <wicket:message key="version"></wicket:message>

>

It is annoying to have a file full of flagged errors when nothing is
wrong.

>

Thanks!
Geoff

>

---
Original message URL: http://devnet.jetbrains.net/message/5292235#5292235


0

Please sign in to leave a comment.