Build 3311 - cannot start using idea.exe

when starting using idea.exe IDEA complains that JAVA_HOME
does not point to a JDK directory, but rather to a JRE,
which in my case is certainly not correct.

Is there any way to set whatever environment correctly
in idea.exe.vmoptions?

Cheers,

Bonny

3 comments
Comment actions Permalink

Yeah... I'm having the same problem. I had to start using idea.bat

0
Comment actions Permalink

It happend to me too because I was using old IDEA.EXE - the one which uses
LAX file. The problem is tools.jar is not in class path I changed JVM to
point to java/bin not in java/jre/bin and everything works

lax.nl.current.vm=c:
java
jdk15
bin
java.exe



"Glen Stampoultzis" <glen.stampoultzis@sensis.com.au> wrote in message
news:27206830.1114647411983.JavaMail.itn@is.intellij.net...

Yeah... I'm having the same problem. I had to start using idea.bat



0
Comment actions Permalink

didn't work for me either ;-(
I fiddled around with environment variables but with no luck.

idea.bat works, however.

I also suggest that they include a "jdk" property in the idea.exe.vmoptions file. It's much easier than having to tweak environment variables under Windows.

As a matter of fact, I've written a Java launcher myself not so long ago, and this is how I'm doing it:
- you can either specify a path to the JDK
- or you can sepcify the desired version (1.5, 1.4) and the launcher retrieves the actual path from the Windows registry

0

Please sign in to leave a comment.