Code inspection errors missing

I have no idea (no pun intended) how I did it, but suddenly all my error indications are turned off in the editor view of IDEA. If I run a build the errors show up, but they give no indication in the editor.

If I select to find the next error I get a balloon "Error analysis is in progress", but this never completes.

A simple example below shows how I can recreate this (note "void" keyword is not completed).

package com.contentwatch.ghoti.api.cmdline;

/**
* Hello world!
*
*/
public class App
{
    public static voi main( String[] args )
    {
        System.out.println( "Hello World!" );
    }
}


Attempting to compile shows the error in the IDE, but there is no indication in the editor of the problem. The little "eye" icon in upper right corner of the editor pane says no problems have been found.

I looked at the Inspection tab in Preferences and all appears normal.

I have searched the forums and googled to no avail. I am sure there is a simple setting or a way to "clear the ide cache" in some way to clear this problem.

This only started showing up recently and I am not sure how it started.

I am running build #IU-103.72 on MacPro i7 with 8 GB ram
5 comments
Comment actions Permalink

Hello Richard,

Please make sure that your Scala, Clojure and Python pugins (if you have
any of them installed) are updated to the latest version.

I have no idea (no pun intended) how I did it, but suddenly all my
error indications are turned off in the editor view of IDEA. If I run
a build the errors show up, but they give no indication in the editor.

If I select to find the next error I get a balloon "Error analysis is
in progress", but this never completes.

A simple example below shows how I can recreate this (note "void"
keyword is not completed).

package com.contentwatch.ghoti.api.cmdline;

/**

  • Hello world!

*
*/
public class App
{
public static voi main( String[] args )
{
System.out.println( "Hello World!" );
}
}
Attempting to compile shows the error in the IDE, but there is no
indication in the editor of the problem. The little "eye" icon in
upper right corner of the editor pane says no problems have been
found.

I looked at the Inspection tab in Preferences and all appears normal.

I have searched the forums and googled to no avail. I am sure there is
a simple setting or a way to "clear the ide cache" in some way to
clear this problem.

This only started showing up recently and I am not sure how it
started.

I am running build #IU-103.72 on MacPro i7 with 8 GB ram

---
Original message URL:
http://devnet.jetbrains.net/message/5290111#5290111


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thank you. Scala was the culprit. That has been on my system for a while but I have not been using it. Not clear why all the sudden it broke things.

0
Comment actions Permalink

I have this same problem, but it only affects some of my files.  I don't have any of the above mentioned plugins installed.

I have restarted/invalidated cache and tried commenting out every line in a class file but I continue to get the "Error analysis in progress" message for every class in the module with no status updates.

0
Comment actions Permalink

Using the 2016.1 version of IntelliJ.

0
Comment actions Permalink

Happening here as well. Started to happen after I updated to 2016.2.3. I've removed the Scala plugin to see if the issue is solved. 

Right now, I'm doing a quick test: Remove some imports and wait the errors to show up. NO errors are displayed but when I press cmd+F9, errors are displayed in the compilation window. Sometimes alt+enter is falling to suggest auto-imports as well...

IntelliJ IDEA 2016.2.3
Build #IU-162.1812.17, built on August 30, 2016
JRE: 1.8.0_112-release-b287 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

 

0

Please sign in to leave a comment.