Rails Developement. Turn off search for gems

I have reported about Intellij becoming very slow after a while ( version 10 )  in this thread:

http://devnet.jetbrains.net/thread/293336?tstart=0

and I believe this has to do with the constant looking for Gems because it keeps turning up at the bottom and try to match or highlight my code using the Rails plugin or something else.

"Scanning for gems requirements" ..

You can see this very quickly at the bottom when editing for example a controller. It gets triggered on every key down or up... not just on save...
I am guessing this is the reason to why Intellij becomes incredibly slow after 2-3 hours and needs to be restarted.

How can I turn this off? I do not need anything to scan for gems all the time.

Cheers, Hamidam

1 comment
Comment actions Permalink

Hello Hamidam, I'm using Idea with Ruby plugin all the time and I don't see the problem with gem requirements scanner. It checks your file to find gems requred for your application so Ruby plugin can provide full code insight support. Also, timeout requred to trigger it has been increased recently, so in future versions it will be triggered less often. However, if you definitely want to disable scanner, you may put ruby.gem.scanner=false into your idea.properties file.

0

Please sign in to leave a comment.