Running IDEA with custom JRE

Is there a way to specify the JRE to run IDEA - when launching IDEA with idea.exe. I tried to put the SET JAVA_EXE... to idea.properties but no luck. I have it working with idea.bat though.

What about adding JGoodies L&F to IDEA? It just looks so sweet & professional when customized right. Maybe I can already do it somehow.. ?

3 comments
Comment actions Permalink

Add -Didea.no.jdk.check=true to the command line and you should be able to run IDEA with your preferred JRE. This is not advisable, for a multitude of reasons. If you ever do this, don't ever fill a bug report.

About JGoodies L&F, unfortunately it won't work. JGoodies extends the Metal L&F, which has some of it's properties modified by IDEA. If you manage to include JGoodies in your classpath, modify your swing.propreties so IDEA can pick them up, you will still get the good-ol-gray background.

0
Comment actions Permalink

Ah I think I explained it badly. I already do have -Didea.no.jdk.check=true set in idea.exe.vmoptions-file. What I don't know, is where to put the path of custom JRE.
With idea.bat, I just change this line: SET JAVA_EXE=C:\Program Files\Java\jdk1.6.0\bin\javaw.exe
But I'm wondering where to put that line when launching from idea.exe. This was easy when idea.lax existed.
I think I could copy the JDK1.6.0 to IDEA jre directory, but I guess there's an easier solution..?

btw. IDEA works flawlessly (after removing -Xrunyjpagent:port=10100 flag) with the latest Mustang build and feels faster too

Dang, IDEA & JGoodies would've been a very nice match.

0
Comment actions Permalink

btw. IDEA works flawlessly (after removing
-Xrunyjpagent:port=10100 flag) with the latest
Mustang build and feels faster too


In my experience, not exactly flawlessly :( There are a couple of dialogs (Generate equals & hashCode, pull up method, move method) that just won't show up if you're running IDEA in 1.5+ JRE's. Something about a change in the way JTable interacts with the underlying TableModel.

0

Please sign in to leave a comment.