Very limited tapestry support in Idea 9

I have downloaded Idea 9M1 release 10781
but Tapestry support is very limited
no support some attributes, navigation works only for limited tags

is it problem of my own configuration or problem of current beta version?


as example not work next components
1. <t:zone t:id="upZone" id="upZone" no navigation to class parameter upZone
2. <t:if test="ognl:step==0" ognl from http://www.chenillekit.org/
3. <t:beaneditor ....
  <p:shortName p:shortName - element does not alowed here....

4. <t:select t:id="firmType" model="literal:0=Option 1,Option 2" - model parameter: can't coerce a String to SelectModel
5. attribute t:mixins does not supported
6. <t:grid source="" press alt enter in attribute - no any selection from parameter of the page
7. <t:pagelink page="client/test"  error for the attribute page - can't resolve symbol
in fact page client/test - exist

8 comments
Comment actions Permalink

Hello, Sergey

1. <t:zone t:id="upZone" id="upZone" no navigation to class parameter upZone

   Navigation is supposed to be working, please file detailed issue.

2. <t:if test="ognl:step==0" ognl from http://www.chenillekit.org/

   As I know ognl is excluded from  standard Tapestry distribution,
   Tapestry Property Expressions are to be supported by IDEA.

3. <t:beaneditor ....
  <p:shortName p:shortName - element does not alowed here....

   Parameter namespaces are not supported yet.

4. <t:select t:id="firmType" model="literal:0=Option 1,Option 2" - model parameter: can't coerce a String to SelectModel

   It's bug, please, file issue.

5. attribute t:mixins does not supported

   Attribute t:mixins is not supported yet.

6. <t:grid source="" press alt enter in attribute - no any selection from parameter of the page

   What selection do you mean?

7. <t:pagelink page="client/test"  error for the attribute page - can't resolve symbol
in fact page client/test - exist

   It's bug, please, file issue.

Thanks,
Alexey

0
Comment actions Permalink

I have create simple sandbox in Idea. I attached idea project to this message as zip arhive

In the project exist Design page as parent component for all pages. Other pages in tap package.
All errors that i have described exist in page Registration.tml and client/FirmView.tml

also in that sandbox idea throw exception in all pages, full stack of the exception you have found in attached zip file - exception.txt



Attachment(s):
sandbox.zip
0
Comment actions Permalink

I have undestand why show error "can't resolve symbol" with <t:pagelink page="client/testPage">.
If specify <t:pagelink page="client.testPage"> error by Idea does not return, but that syntax is wrong for tapestry

0
Comment actions Permalink

Sergey,

The bug is fixed.

Sergey Kashin wrote:

Error "can'r resolve symbol" with <t:pagelink page="client/testPage"> is a bug.
if specify <t:pagelink page="client.testPage"> error by Idea does not return, but that syntax is wrong for tapestry

---
Original message URL: http://www.jetbrains.net/devnet/message/5246188#5246188

0
Comment actions Permalink

How about other bugs? Is all clear with reproduce?

0
Comment actions Permalink

Do you found all decribded bugs?

0
Comment actions Permalink

Yes, Sergey

some of them are already fixed and others will be fixed in service
releases (IDEA 9.1, 9.2)

Alexey

Sergey Kashin wrote:

Do you found all decribded bugs?

---
Original message URL: http://www.jetbrains.net/devnet/message/5246965#5246965

0
Comment actions Permalink

I apologize if this is not the right place to post this, but it's the only thread I could find related to what I'm experiencing.  I believe I have an environment configuration issue, but I'm not sure.  I've been mostly a back-end developer and haven't dealt much with web-based projects but I'm starting to tinker and am doing so with Tapestry.

I've downloaded and installed the http://tapestry.apache.org/schema/tapestry_5_1_0.xsd into my resources configuration but I'm seeing inspection-based errors to what I'm guessing are valid Tapestry elements.  The following code snippets were generated when I leveraged the "mvn archetype:generate -DarchetypeCatalog=http://tapestry.apache.org" command to generate a Tapestry project.  So, I'm assuming some of what's generated should be correct.

1) <html t:type="layout" xmlns:t="http://tapestry.apache.org/schema/tapestry_5_1_0.xsd" xmlns:p="tapestry:parameter"> - The "layout" value of t:type is marked as a symbol that can't be recognized and the xmlns:p="tapestry:parameter" namespace declaration is not found (doesn't recognize the URI).  From my reading on http://tapestry.apache.org/tapestry5/guide/templates.html I see that the parameter or ajax namespaces are library namespaces, but I could figure out how to tell IntelliJ what to do with it.  I was hoping for intellisense support here, but I don't know if that's possible.

2) "t:zone" is not recognized and according to the specs this is valid.  Am I configured wrong?

3) Certain parameters are marked as not being valid: <a t:page="..."...>  in that t:page does not validate; the message I get is that "t:page" is not allowed here.

Any suggestions on what I might try?  I unfortunately am too new to the IntelliJ web support features to really know what all I should provide in terms of environment info.  Happy to provide more details if someone will let me know what's needed.

-Alan

0

Please sign in to leave a comment.