Mac - Java app (include IDEA) won't shutdown

I have to force quit most of my java applications.  I thought maybe it was
64bit issue, but it even happens with 32bit java.

I've had this happen with IDEA, DbVisualizer, SQLDeveloper, JDeveloper (not sure about others).

It's driving me crazy since IDEA needs to rebuild the indexes on every startup.

I just up'd the memory to IDEA to 1g to make sure it isn't a out of memory error, but I really don't think it is.  When I last killed idea it wasn't at the limit of 768m.

Anyone else have this problem with this setup?  I don't use Eclipse so I'm not sure if it will have the same problem.

osx 10.6.4
java version "1.6.0_20"


I use that same configuration (10.6.4 and 1.6_20) and I don't have that issue. Have you checked /var/log/system.log to see if it is telling you anything helpful?


Not yet.  But I'm going to start tailing it.  There were a ton of expections in there for IDEA, but only after killing it.

I did up mine to 6gig of ram.  Replaced one 2gig for a 4gig.  Wish I remember when this started to happen!


No idea what's wrong but have you tried:

- looking at a threaddump of the app that's trying to close. If IDEA thinks
it needs to rebuild indexes, there must still be some Java thread blocking
that's preventing a clean shutdown. Maybe that'll give you a hint as to the
source of the problem
- monitoring CPU, memory, threads, filesystem use while the app is "hung"
- a different Java version

Not yet.  But I'm going to start tailing it.  There were a ton of
expections in there for IDEA, but only after killing it.

I did up mine to 6gig of ram.  Replaced one 2gig for a 4gig.  Wish I
remember when this started to happen!

Original message URL:


If I wait a good 2-5 minutes it will eventually shutdown it seems.  Guess I'm not patient enough...  :-)

I've attached a thread dump and a couple sample processes.  Seems there a bunch of threads running while it's shutting down having something to do with RMI?  I ran VisualVM against it and I could see them running.

Sample of IntelliJ
Sample of IntelliJ

It has something to do with networking.  Just now it wouldn't shutdown.  I turned off AirPort and it shutdown immediatly.  I noticed
this happen a little while ago also, but hadn't had a chance to test it.  In that case I unplugged my network cable and it shutdown.

Any idea what it could possibly be doing?


On IDEA 10.0, this started happening for me (IDEA would not shut down).  I suspect it was because I occasionally have to hard-reboot my mac, thus not allowing a graceful shutdown of IDEA.  Thankfully, upgrading to 10.1 fixed the problem.


Please sign in to leave a comment.