Reformat Code bug

There's an odd bug in the Reformat Code feature in build 3245. Occasionally, method comments get formatted incorrectly. For example:

/**

  • Gets all SkillGroupMember records that contain the specified SkillTargetID.

*

  • @param agentSkillTargetId

  • @return Collection of Cms_Skill_Group_Member records

  • @throws SPLKConnectionException

  • @throws ConapiDataAccessException

*/

Notice how the comment lines after the first line are all indented by 5 spaces? The first line is the only one properly lined up. It should be noted that before running Reformat Code, that this method comment was properly lined up and that the Reformat Code feature messed it up. Also, if I run Reformat Code two or three times in a row the problem seems to go away and the indenting is correct. I have yet to figure out what pattern causes this problem.

I haven't tried this in 3260 because I can't use that build so I don't know if the problem exists there too.

Please sign in to leave a comment.