How can I disable property bundle errors in flex mxml-files?

When editing flex mxml-files in our project, all calls to resourceManager.getString is marked as an error: "Cannot resolve property bundle".

cant_resolve_bundle.jpg

The project has a number of flex-client modules and corresponding java-server modules. The bundle property-files live in the server module and at build time Maven, with the help of some plugin, puts the bundle files where they need to be. I guess this is why Idea can't find the bundle. So, I just want to disable the error inspection but I can't figure out which inspection is causing the error.

Is it possible to disable?

Best regards,

/Jörgen Lundberg



Attachment(s):
cant_resolve_bundle.jpg
2 comments
Comment actions Permalink

Yes, IDEA is looking for resource bundles in source folders. It is not possible to disable this check.

0
Comment actions Permalink

For anyone else who is having this problem, I got rid of the error highlights by adding the <server_module>/src/main/resources/.../<bundle-dir> as a content root and then marking the folder as a src-folder in my flex module.

I noticed however, that you still get the bundle error if you don't have a default bundle. In our case we have a en_US and a se_SV bundle but no default. So I ended up copying the en_US.

Cheers,

Jörgen Lundberg

0

Please sign in to leave a comment.