IDEA 10.0.1 Slowing down after a while. Memory Hog!?

I have assigned 1536 MB as :

-Xms1536m
-Xmx1536m
-XX:MaxPermSize=250m
-ea



This was plenty in 9, today I am using 10.0.1 and I have had to restart the application twice today because editing started to go in slow motion.
I doubt it will help to assign more to it. It's on 683 MB out of 1528 MB in the right bottom label.. why is it becoming slow?

Anyone else experiencing this ? Ubuntu 10.x .

Cheers / Hamidam
4 comments
Comment actions Permalink

Hello,

Please provide profiler snapshots for the problem situation.

Denis

0
Comment actions Permalink

You should not give such a big heap to IDEA. Too big heap has some negative side effects. Even 500-700Mb is usually enough for projects with > 60 000 files. When IDEA becomes slow please take CPU snapshot and create an issue. Details are here: http://devnet.jetbrains.net/docs/DOC-192

0
Comment actions Permalink

why are you setting minimum heap (

-Xms) so high?
0
Comment actions Permalink

So what is good settings then ?

I am willing to give it up to 1536MB, how should these be assigned regarding to xmx and xms ?

I have a quad core, 8 GB ram, Uubuntu 10.x (64 bit) , Nvidia graphics card...

Cheers, Hamidam

0

Please sign in to leave a comment.