IntelliJ 10 fails to start after java update on Mac OSX

Yesterday I installed the latest 1.6.x preview version of de java jdk on my mac and now I have trouble starting IntelliJ 10.

This is what I see in the Console.app when I try to start IntelliJ

2011-10-01 01:05:37    [0x0-0x92092].com.jetbrains.intellij[1000]    [JavaAppLauncher Error] Failed to re-execute into [i386] from [x86_64]
2011-10-01 01:05:37    [0x0-0x92092].com.jetbrains.intellij[1000]    [JavaAppLauncher Error] unable to find a version of Java to launch
2011-10-01 01:05:37    com.apple.launchd.peruser.501[189]    ([0x0-0x92092].com.jetbrains.intellij[1000]) Exited with exit code: 1

I tried to select another JDK with the Java Preferences.app but nothing seems to work.
I even copied another JavaApplicationStub over  /Applications/IntelliJ IDEA 10.app/Contents/MacOS/idea but that also didn't work (i found this somewhere else on this site)

I read on the apple site (too late) that Java versions installed cannot be reverted without re-installing the OS. Well I hope there is another solutions because that is not something I would like to do!

Can anybody help me?

Thanks,
Ivo.

1 comment
Comment actions Permalink

Fixed it after a very helpfull chat with Serge Baranov by doing the following:

Try to edit /Applications/IntelliJ IDEA 10.app/Contents/Info.plist file, there should be the
following lines:

    <key>JVMArchs</key>
     <array>
       <string>i386</string>
       <string>x86_64</string>
       <string>ppc</string>
     </array>

     <key>LSArchitecturePriority</key>
     <array>
       <string>i386</string>
       <string>x86_64</string>
       <string>ppc</string>
     </array>

Leave only x86_64 so that it becomes:

    <key>JVMArchs</key>
     <array>
       <string>x86_64</string>
     </array>

     <key>LSArchitecturePriority</key>
     <array>
       <string>x86_64</string>
     </array>

Hope this will be helpfull for those with the same problem.
Greetz,
Ivo.

0

Please sign in to leave a comment.