3229 problem

I have the following configuration: Slackware Linux, IDEA 3329 and JRE 3136.
When I try to start idea I got:
"java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at
com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:1)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsupportedClassVersionError: com/sun/jdi/Field
(Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at
com.intellij.ide.plugins.cl.IdeaClassLoader.a(IdeaClassLoader.java:7)
at
com.intellij.ide.plugins.cl.IdeaClassLoader.findClass(IdeaClassLoader.java:35)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.intellij.idea.Main.checkJdkVersion(Main.java:26)
at com.intellij.idea.Main.checkStartupPossible(Main.java:18)
at com.intellij.idea.Main.start(Main.java:45)
... 6 more
ERROR:
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at
com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:1)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsupportedClassVersionError: com/sun/jdi/Field
(Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at
com.intellij.ide.plugins.cl.IdeaClassLoader.a(IdeaClassLoader.java:7)
at
com.intellij.ide.plugins.cl.IdeaClassLoader.findClass(IdeaClassLoader.java:35)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.intellij.idea.Main.checkJdkVersion(Main.java:26)
at com.intellij.idea.Main.checkStartupPossible(Main.java:18)
at com.intellij.idea.Main.start(Main.java:45)
... 6 more
ERROR:
java.lang.AssertionError:
at
com.intellij.openapi.diagnostic.DefaultLogger.error(DefaultLogger.java:33)
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:46)
at
com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:8)
at java.lang.Thread.run(Unknown Source)"


Switched to JRE 1.5.0_01... now I have a dialog box:
"The JDK version is 1.5.0_01. IDEA requires 1.4.2_06". :-((

Thanks,
Adi





Please sign in to leave a comment.