Problem with package automatically prefixing classes rather than being added to imports

I have a problem that just recently started (about the time I installed the latest 10.x patch).

When I type in a class, it is automatically prefixed with the full package name.  I'd prefer it to either automatically be added to the imports or prompt me to add to imports.  Currently, I have to type in the class name, then await the tip asking if I'd like to change the fully qualified class name to an import.

I'm sure this is a setting in options, but I can't seem to find which one.

Any help would be welcome.

TIA,
Todd

2 comments
Comment actions Permalink

Hello todd,

The setting is at Code Style | Imports | Use fully qualified class names

I have a problem that just recently started (about the time I
installed the latest 10.x patch).

When I type in a class, it is automatically prefixed with the full
package name.  I'd prefer it to either automatically be added to the
imports or prompt me to add to imports.  Currently, I have to type in
the class name, then await the tip asking if I'd like to change the
fully qualified class name to an import.

I'm sure this is a setting in options, but I can't seem to find which
one.

Any help would be welcome.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks Dmitry!  Worked like a charm.

0

Please sign in to leave a comment.