idea 10.0 Annotate

I recently installed Idea 10.0 and started reviwing it.

Whenever I "Annotate" the code, I get "revnum date LAN n". The last piece of the annotation, correspoding to the user that last updated that line of code,
shows as "LAN n" (e.g., LAN 2) , instead of the name of the user that last modified that line of code.

We use subversion.  Is there a new setting I should be aware of?


Gisella Saavedra

Comment actions Permalink

Right-click on the annotations and choose information you want to see under
"View" submenu

Comment actions Permalink

That still does not solve the problem completelly.

. I can see the name of "LAN n" when I right-click and then choose "Show before" to see the author. So, this takes two more clicks.
. In the default "Annotate" section, I see some names and then some of the other names are "LAN n".

. In the mixed name case, when I right-click, and then click "View", the "Author" is grayed out.

What is the criteria for showing some names correctly and some as LAN n, in the Annotate section?
It is annoying having to click two more times to see all the names.

Comment actions Permalink

The mail goal of new Annotation tool is to customize its view. So, for instance, in subversion and many others VCS user names are shown something like this:

John Doe <>
It's too long, cuz you probably know all coders in your project. Short names option makes this line shorter:


Numbers after user name is Commit Number option. 1 is the first commit and so on.

All options are global. So, if you annotated a file and unclick SHORT NAMES option it won't appears in the next files.

Comment actions Permalink

I get it now.  Then, it is a bug,

The full name is:
and the "Short Name" is showing LAN instead of "doe" or "john.doe" or "john"

Everybody within a company will likely have the same domain, showing the last piece of the user's URI, e.g., e-mail or else, (URI having a domain)  like "LAN" or "COM" is incorrect.
Seeing all names as LAN or COM makes the "Short Names" option useless.
Please mark this as a bug.




Please sign in to leave a comment.