Using git within IDEA - how do I avoid passphrase private key prompt?

I'm using IDEA on a git project that isn't using a private key - I simply provide and ssh password when using the repo from the command line. When I'm trying to use this repo for a project within IDEA, it constantly prompts me for a passphrase as shown in this scren capture http://img.skitch.com/20101111-6wqiwgy2f1h58q9e7p741jij4.jpg

I do have a private key at .ssh/id_rsa but that's for use with other git accounts like github.

How do I avoid this passphrase prompt for the project I'm working with since it doesn't require any keys. If I temporarily move my .ssh directory and then try to use git with this project, things are fine, I get just the single ssh password prompt for the project as expected.

2 comments
Comment actions Permalink

Should I post this as a bug? I noticed I have the same problem in IDEA X eap. I can't be the only one that is seeing this issue?

0
Comment actions Permalink

Hi Rick,

To solve your problem you can specify the preferred method of authentication for your host in .ssh/config
For example:

Host myhost.com  
  PreferredAuthentications password,publickey

Here I specified, that for host myhost.com ssh should at first ask me for a password and only then try looking into public key.
See http://www.openbsd.org/cgi-bin/man.cgi?query=ssh_config for a complete list of ssh configuration options.
If you don't have .ssh/config file, just create it and add these options.

I've opened a request for IDEA to make a user-friendly interface to configure ssh connection.
You may vote for it: http://youtrack.jetbrains.net/issue/IDEA-61321

0

Please sign in to leave a comment.