IntelliJ 9.0.3 on linux won't recognize .obj resources

I'm working on a project which makes use of Wavefront .obj 3D models and I can't get IntelliJ Community Edition 9.0.3 on Linux to recognize my model in the project pane.  It also fails to copy the file over to the out directory on make.  Note that this problem only seems to affect the Linux version.  I run Ultimate Edition at home on Windows 7, and it detects the .obj file just fine.

Here's what I've done:

1. Make a directory structure like "assets/Models" such that "assets" is a sibling of "src" in the project root.  Put "Tank.obj" in the "Models" directory.  (Note that I've tested with specifically this one file and others, and it doesn't seem to depend on this particular file-- I'm able to reproduce with any old blank file with a .obj extension).

2. Mark "assets" as a Source root in the Project settings dialog.

3. Add ";?*.obj" to the end of the resource pattens list in Project Settings-> Compiler.  Here's my full pattern string in quotes: "?*.properties;?*.xml;?*.gif;?*.png;?*.jpeg;?*.jpg;?*.html;?*.dtd;?*.tld;?*.ftl;?*.fnt;?*.j3md;?*.vert;?*.frag;?*.glsllib;?*.obj;?*.j3m;*.wav" (It's 3 from the end).

At this point, IntelliJ on Windows recognizes the .obj file just fine, but I haven't been able to get the Linux version to recognize it at all.  If I rename the .obj file to "Tank.obj.properties", then it gets recognized by the Linux version and copied on make without problems.

Any help would be appreciated.

2 comments

Hello Josh,

Please make sure that *.obj is not listed in Settings | File Types | Files
and folders to ignore on your Linux installation.

I'm working on a project which makes use of Wavefront .obj 3D models
and I can't get IntelliJ Community Edition 9.0.3 on Linux to recognize
my model in the project pane.  It also fails to copy the file over to
the out directory on make.  Note that this problem only seems to
affect the Linux version.  I run Ultimate Edition at home on Windows
7, and it detects the .obj file just fine.

Here's what I've done:

1. Make a directory structure like "assets/Models" such that "assets"
is a sibling of "src" in the project root.  Put "Tank.obj" in the
"Models" directory.  (Note that I've tested with specifically this one
file and others, and it doesn't seem to depend on this particular
file-- I'm able to reproduce with any old blank file with a .obj
extension).

2. Mark "assets" as a Source root in the Project settings dialog.

3. Add ";?*.obj" to the end of the resource pattens list in Project
Settings-> Compiler.  Here's my full pattern string in quotes:
"?.properties;?.xml;?.gif;?.png;?.jpeg;?.jpg;?.html;?.dtd;?*.t
ld;?.ftl;?.fnt;?.j3md;?.vert;?.frag;?.glsllib;?.obj;?.j3m;*.wa
v" (It's 3 from the end).

At this point, IntelliJ on Windows recognizes the .obj file just fine,
but I haven't been able to get the Linux version to recognize it at
all.  If I rename the .obj file to "Tank.obj.properties", then it gets
recognized by the Linux version and copied on make without problems.

Any help would be appreciated.

---
Original message URL:
http://devnet.jetbrains.net/message/5277089#5277089


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

It was in fact listed under the ignored list.

Thanks for the prompt response!

0

Please sign in to leave a comment.