Air filesize really big

Hello all,

I'm new with Intellij Idea. I'm trying to develop Air applications with it on Linux Ubuntu 10.10.
This IDE seems to be exactly what I want, but ...

My problem is the production air filesize are really bigger than air files created with fb4linux. I use the same sdk -> 4.1.0 for my tests.

With FB4Linux : 381 Ko
With Intellij Idea : 912 Ko

Here is the simple code :

<?xml version="1.0"?> <s:WindowedApplication xmlns:fx=""                             xmlns:s="library://"                             xmlns:mx="library://">      <fx:Declarations>           <!-- Placer ici les éléments non visuels (services et objets de valeur, par exemple). -->      </fx:Declarations>      <s:Button label="Test"                  click="onClick(event)"/>      <fx:Script>           <![CDATA[                import mx.controls.Alert;                protected function onClick(event:MouseEvent):void                {            as Button).label);                }           ]]>      </fx:Script> </s:WindowedApplication>

Is someone can say me what's wrong with Intellij Idea with the package air installtion filesize? Maybe I do something wrong ...

Thanks a lot.
Comment actions Permalink

I'm really sorry, but I've found my error.

I give it to others like me ;)

In fact, I was in debug mode, and I didn't know how to make release builds.

  1. Right click on any project and select module setting.
  2. Select tab "Flex compiler setting"
  3. Last field on this tab is "Additional compiler options:" add "-debug=false" without double quotes to it.
  4. do a project Rebuild and you will get a smaller swf.

Now it's good, air files size are the same if I develop on Flash Builder, FDT, FB4Linux or now Intellij Idea.

Comment actions Permalink

If you have dozens of Flex/AIR modules is it not convenient to manually write Additional compiler options. You'd better use File | Settings | Compiler | Flex Compiler | Include debugging info option which changes behavior for the whole project. Note that Additional compiler options that you wrote about have precedence, so you need to remove -debug=whatever from there.


Please sign in to leave a comment.