How do i set up my new Flex Project to ...........

Hi All

When i am setting up a new Flex Project, how do i configure the output so that it points to apache/coldfusion servers .. my server dir is /srv/http

Many Thanks

6 comments
Comment actions Permalink

Flex compiler oputput is configured at File | Project Structure | Modules | <your module> | Flex Compiler Settings tab, there check 'Use module compile output path' and specify path.
Also you may find it useful to use Artifacts instead (File | Project Structure | Artifacts). http://blogs.jetbrains.com/idea/2009/10/new-packaging-configurations/

0
Comment actions Permalink

Hi Alexander

I'm still not certain how to configure the project to output to either apache or coldfusion ... I tried what was suggested, but i only get the swf sent to my /srv/http folder and i dont get the html wrapper ...

Many Thanks

0
Comment actions Permalink

When you compile project in IDEA it copies all resource files from source folders to output folder. Make sure that your html template is in source folder. Make sure that ?*.html pattern is listed in File | Settings | Compiler | Resource patterns. Uncheck 'Clear output directory on rebuild' if you like. Try Build | Rebuild Project.

0
Comment actions Permalink

Alexander .... Still cant see where to set the project output path to my local server ... ?

I also noticed that in 9, when you right clicked on the project there was a create on server option but not in Idea X EAP ... How come ?

Many thanks Plus i'm really starting to enjoy Intellij Idea EAP with Flex :D

0
Comment actions Permalink

'Create on server' creates PHP run configuration. It is not related to our discussion.

I explained how to configure output folder where compiled SWF will be placed and where resource files from source folders will be copied. If it doesn't help I'm afraid I don't understand your question. Can you please provide details and/or give an example?

0
Comment actions Permalink

Sorry Alexander, my mistake, i got there in the end, i had just missed where you set the server path ....

Duh lol

0

Please sign in to leave a comment.