30 comments

Hi,

This will have chance to happen when 1.5 will be stable enough on Mac.

Alexey Efimov wrote:

Hello,

JDK 1.5 released, then IDEA will have it as JRE? :)
- Garbage collection is improved :)))

Thanks!
--
Alexey Efimov, Java Developer
Tops-BI
http://www.topsbi.ru



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

This will have chance to happen when 1.5 will be
stable enough on Mac.


And can we use it somehow in Windows/Linux?

0

Hello, Alexander!
You wrote on Fri, 1 Oct 2004 14:04:27 +0400 (MSD):

AB> And can we use it somehow in Windows/Linux?

:)))

BTW
--
Alexey Efimov, Java Developer
Tops-BI
http://www.topsbi.ru


0

Hello, Alexander!
You wrote on Fri, 1 Oct 2004 14:04:27 +0400 (MSD):

AB> And can we use it somehow in Windows/Linux?

:)))


As far as I remember, Idea checks the JRE version it uses. And if I change JRE, program won't start at all. Am I wrong?

0

You can get Idea to ignore the version and it will start up under JDK 1.5, but the Idea debugger doesnt work(at least on Linux) since Sun changed the names of some "internal" classes that Idea seems to use.

Nick

0

That's probably one of the best answers I've read on this subject. Thank you Maxim!

R

0

Just to let you know, "the debugger doesn't work on linux" isn't true. I run IDEA on JDK5 and debugging Tomcat applications works fine for me.

0

Robert S. Sfeir wrote:

That's probably one of the best answers I've read on this subject. Thank you Maxim!

R


This is not the whole truth unfortunately. Even if 1.5 appears stable
under Mac it will only run under Tiger which is not released itself.
This way IDEA will loose all the users who won't upgrade from Panther
since supporting both 1.4 and 1.5 platforms is the way too complicated task.

I suspect IDEA is not the only app that faced up with necessity to take
this hard decision. The only thing left to think about is the way Apple
takes its business here...

--
Maxim Shafirov
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

So are you saying that because of this you're opting to not go full jdk 5.0, or are you saying you might have to drop Macs?

Tiger will be out in Jan, how many move to it is always a guess.

Yes I agree that Apple has some very bizarre approaches to their JDK support, and why JDK 5.0 on Tiger only is a mystery to me, unless they intend to seriously hardwire the display stuff to their new Core Image technology? (Not entirely sure it would be useful but...)

Anyway... I'm hoping that IDEA doesn't toss Mac support over board because of it in Irida.

Thanks
R

0

Robert S. Sfeir wrote:

I'm hoping that IDEA doesn't toss Mac support over board because of it in Irida.

The option of dropping Mac support is not considered seriously. Well at
least for the best of my knowledge. I'm not the persion who takes
business decisions here.

--
Maxim Shafirov
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Intersting...I'm using a similar env and I can't get Idea to start using JDK 5.0 (several NoClassDefFound exceptions).

Did you do anything else to get this working (aside from -Didea.no.jdk.check)?

0

Hi,

Try removing gjc-rt.jar from boot classpath.

Ryan Lubke wrote:

Intersting...I'm using a similar env and I can't get Idea to start using JDK 5.0 (several NoClassDefFound exceptions).

Did you do anything else to get this working (aside from -Didea.no.jdk.check)?



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

This library JAR doesn't exist on my filesystem.

0

try to copy tools.jar from the 1.4.2 jdk... at least for me it began to debug...

0

Ah, right. I forgot about the tools.jar. I copied this from my jdk1.5.0/lib to jdk1.5.0/jre/lib directory and all was well.

Thanks for the reminder.

0

And the people who are in charge of it own a 17", as I remember right?

0

From a technical point of view: are there any reasons that require you to make the move for the JRE that runs IDEA to 1.5 immediately? Are there limitations like debugging or compiling 1.5 projects does not work properly? What about speed?

From what I have read between the lines, you are already using generics internally. I guess that makes developing a little more pleasure than without.

Personally, I would feel very sad if you dropped OS X support. But I am not running your business and I am only contributing a little money with my educational license... Although, it is vey unlikely, I still hope that there will be 1.5 for Panther (especially, as the Apple JVM is far from being perfect).

Best,

Dirk Dittert

0

Hi,

Our initial experience running IDEA with JDK 1.5 is quite unpleasant,
namely: more often out of memory error (sometimes even when there is a
plenty of it), jvm native code crashes, compiler problems.
From the positive side we found several generics related problems in
the code.

Dirk Dittert wrote:

From a technical point of view: are there any reasons that require you to make the move for the JRE that runs IDEA to 1.5 immediately? Are there limitations like debugging or compiling 1.5 projects does not work properly? What about speed?

From what I have read between the lines, you are already using generics internally. I guess that makes developing a little more pleasure than without.

Personally, I would feel very sad if you dropped OS X support. But I am not running your business and I am only contributing a little money with my educational license... Although, it is vey unlikely, I still hope that there will be 1.5 for Panther (especially, as the Apple JVM is far from being perfect).

Best,

Dirk Dittert



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Well, I'm running WinXP/java 1.5/idea 2242 - The menus have some strange spaces below the last menu item, but the rest is nice'n'cool, the garbage collection is really visibly better.

0

Hi,

Well, just wonder, does the Control + Alt + Shift + N work properly for
nonexistent name (both with checkbox search in libs set and not).

lllopo wrote:

Well, I'm running WinXP/java 1.5/idea 2242 - The menus have some strange spaces below the last menu item, but the rest is nice'n'cool, the garbage collection is really visibly better.



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

I can run IDEA under Java 5 almost fine. There are a few dialogs that refuse to show (Generate -> equals and hashCode comes to my mind right now), an issue probably related to a behaviour change in JTable, already found out and "patched" by Roman Dawydkin[1].

Other than that, and the already mentioned menu weirdness, everything seems to be OK, with WAY better font anti-aliasing, specially on dark backgrounds, and a noticeable more efficient Garbage Collection, specially when you don't tune any of the VM options. Reading the "Garbage Collection Ergonomics"[2] document will help understand that.

http://chmmr.narod.ru/java/idea
http://java.sun.com/j2se/1.5.0/docs/guide/vm/gc-ergonomics.html

0

Do U have something in mind, because seems to work ok for me - if the string doesn't exist > gets red, that's all.

0

You can get Idea to ignore the version and it will
start up under JDK 1.5, but the Idea debugger doesnt
work(at least on Linux) since Sun changed the names
of some "internal" classes that Idea seems to use.

Nick


Can you describe how you get Idea to ignore the JVM version? I haven't had any luck editing idea.lax.

0

Well, I'm running WinXP/java 1.5/idea 2242 - The
menus have some strange spaces below the last menu
item


Set parameter IDEA_POPUP_WEIGHT=medium in idea.bat, this will help.

0

I can't seem to make this work :(
I've altered idea.sh to use the 1.5 JAVA_HOME, and applied the patch from http://chmmr.narod.ru/java/idea/.
I've also given -Didea.no.jdk.check=1 as a JVm argument, yet I still get 'IDEA is not configured properly. The application should be run with the supplied JRE'.

What have I missed ?

0

Parameter must be -Didea.no.jdk.check=true

Also see my new message in this thread.

0

I have update patch on my home page to version 3144 (Irida). It's still not possible to debug due to significant changes in Java debugger API between 1.4 and 1.5, but I don't use it either.

Also, to run under 1.5 I've disabled profiler by commenting out JVM parameter -Xrunyjpagent:port=10100. Maybe it's not necessary.

There are still some exceptions appearing, which can be ignored by pressing Esc.

0

Great, that was it, cheers !
The latest 4.5.3 (build 2250) IDEA now runs under 1.5, rar

Incidently, is the 1.4 JVM it ships with patched against the sandbox security issues etc., does anyone know ? If the answer is 'no', then offical 1.5 support must be a high priority !

0

Please sign in to leave a comment.