Trouble installing Intellij ......

Hi All

Right i am trying to install Intellij on Xubuntu 10:10 and i get this error


No JDK found to run IDEA. Please validate either IDEA_JDK or JDK_HOME points to valid JDK installation
exec: 67: /bin/java: not found

This is my bashrc environment settings

## JAVA_HOME ##
export JAVA_HOME=/usr/lib/jvm/jdk1.6.0_21
export PATH=$PATH:$JAVA_HOME/bin

## JDK_HOME ##
export JDK_HOME=/usr/lib/jvm/jdk1.6.0_21
export PATH=$PATH:$JDK_HOME/bin

## IDEA_JDK ##
export IDEA_JDK=/usr/lib/jvm/jdk1.6.0_21
export PATH=$PATH:$IDEA_JDK/bin

export JRE_HOME=/usr/lib/jvm/jdk1.6.0_21/jre
export PATH=$PATH:$JRE_HOME/bin

Any suggestions please ???

Many thanks

3 comments

Hello Julian,

If you're setting the environment variables in .bashrc, they won't be picked
up when you run IntelliJ IDEA from a desktop shortcut. You'll need to define
them globally.

Hi All

Right i am trying to install Intellij on Xubuntu 10:10 and i get this
error

No JDK found to run IDEA. Please validate either IDEA_JDK or JDK_HOME
points to valid JDK installation

exec: 67: /bin/java: not found

This is my bashrc environment settings

    1. JAVA_HOME ##

export JAVA_HOME=/usr/lib/jvm/jdk1.6.0_21
export PATH=$PATH:$JAVA_HOME/bin

    1. JDK_HOME ##

export JDK_HOME=/usr/lib/jvm/jdk1.6.0_21
export PATH=$PATH:$JDK_HOME/bin

    1. IDEA_JDK ##

export IDEA_JDK=/usr/lib/jvm/jdk1.6.0_21
export PATH=$PATH:$IDEA_JDK/bin
export JRE_HOME=/usr/lib/jvm/jdk1.6.0_21/jre
export PATH=$PATH:$JRE_HOME/bin
Any suggestions please ???

Many thanks

---
Original message URL:
http://devnet.jetbrains.net/message/5275640#5275640


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Hi Julian,

Please check this thread for IJ Linux configuration details.

Regards, Denis

0

Hello Dmitry

Well i have just downloaded the trial again, and this time it works straight away ... Excellent

So what would be the best way to create a menu instead of from terminal ?

Many thanks

0

Please sign in to leave a comment.