Visual Paradigm Integration

I have recently installed IntelliJ Idea 9.0.3.  Before that, I was running version 7.0.5.  It was integrated with Visual Paradigm SDE 4.1 and worked.  However, VP SDE 4.1 does not work for version 9.0.3.  I cannot open any of the diagrams in the editor.  Here is the error that Idea logs:


Error during dispatching of java.awt.event.MouseEvent[MOUSE_CLICKED,(160,236),absolute(160,236),button=1,modifiers=Button1,clickCount=2] on frame0
java.lang.AbstractMethodError
    at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImpl3(FileEditorManagerImpl.java:519)
    at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl$5.run(FileEditorManagerImpl.java:451)
    at com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(CommandProcessorImpl.java:110)
    at com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(CommandProcessorImpl.java:86)
    at com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(CommandProcessorImpl.java:78)
    at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImpl2(FileEditorManagerImpl.java:449)
    at com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileWithProviders(FileEditorManagerImpl.java:443)
    at com.intellij.openapi.fileEditor.ex.FileEditorManagerEx.openFile(FileEditorManagerEx.java:107)
    at v.mcr.f(:226)
    at v.cgd.i(:44)
    at v.cgd.compute(:48)
    at com.intellij.openapi.application.impl.ApplicationImpl$11.run(ApplicationImpl.java:774)
    at com.intellij.openapi.application.impl.ApplicationImpl.runWriteAction(ApplicationImpl.java:754)
    at com.intellij.openapi.application.impl.ApplicationImpl.runWriteAction(ApplicationImpl.java:772)
    at v.uat.i(:42)
    at v.dxs.i(:20)
    at v.bdk.f(:1003)
    at v.pgi.i(:119)
    at v.pgi.i(:115)
    at v.iqzb.f(:2486)
    at v.imbw.f(:36)
    at v.imbw.i(:31)
    at v.iiep.i(:412)
    at v.iiep.o(:399)
    at v.fum.i(:27)
    at v.iigt.o(:216)
    at v.iigt.d(:35)
    at v.wqe.mouseClicked(:77)
    at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:253)
    at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:252)
    at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:252)
    at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:252)
    at java.awt.Component.processMouseEvent(Component.java:6266)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
    at java.awt.Component.processEvent(Component.java:6028)
    at java.awt.Container.processEvent(Container.java:2041)
    at java.awt.Component.dispatchEventImpl(Component.java:4630)
    at java.awt.Container.dispatchEventImpl(Container.java:2099)
    at java.awt.Component.dispatchEvent(Component.java:4460)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4247)
    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
    at java.awt.Container.dispatchEventImpl(Container.java:2085)
    at java.awt.Window.dispatchEventImpl(Window.java:2475)
    at java.awt.Component.dispatchEvent(Component.java:4460)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
    at com.intellij.ide.IdeEventQueue.f(IdeEventQueue.java:610)
    at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:496)
    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:368)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)



I am on Windows XP (32 bit).  If anyone knows about this, please advise.  Thank you.

5 comments

Hello Pasha,

Please contact the developers of Visual Paradigm and request them to update
the plugin for compatibility with the latest version of IntelliJ IDEA.

I have recently installed IntelliJ Idea 9.0.3.  Before that, I was
running version 7.0.5.  It was integrated with Visual Paradigm SDE 4.1
and worked.  However, VP SDE 4.1 does not work for version 9.0.3.  I
cannot open any of the diagrams in the editor.  Here is the error that
Idea logs:

Error during dispatching of
java.awt.event.MouseEvent[MOUSE_CLICKED,(160,236),absolute(160,236),bu
tton=1,modifiers=Button1,clickCount=2] on frame0
java.lang.AbstractMethodError
at
com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImp
l3(FileEditorManagerImpl.java:519)
at
com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl$5.run(FileE
ditorManagerImpl.java:451)
at
com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(
CommandProcessorImpl.java:110)
at
com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(
CommandProcessorImpl.java:86)
at
com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(
CommandProcessorImpl.java:78)
at
com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileImp
l2(FileEditorManagerImpl.java:449)
at
com.intellij.openapi.fileEditor.impl.FileEditorManagerImpl.openFileWit
hProviders(FileEditorManagerImpl.java:443)
at
com.intellij.openapi.fileEditor.ex.FileEditorManagerEx.openFile(FileEd
itorManagerEx.java:107)
at v.mcr.f(:226)
at v.cgd.i(:44)
at v.cgd.compute(:48)
at
com.intellij.openapi.application.impl.ApplicationImpl$11.run(Applicati
onImpl.java:774)
at
com.intellij.openapi.application.impl.ApplicationImpl.runWriteAction(A
pplicationImpl.java:754)
at
com.intellij.openapi.application.impl.ApplicationImpl.runWriteAction(A
pplicationImpl.java:772)
at v.uat.i(:42)
at v.dxs.i(:20)
at v.bdk.f(:1003)
at v.pgi.i(:119)
at v.pgi.i(:115)
at v.iqzb.f(:2486)
at v.imbw.f(:36)
at v.imbw.i(:31)
at v.iiep.i(:412)
at v.iiep.o(:399)
at v.fum.i(:27)
at v.iigt.o(:216)
at v.iigt.d(:35)
at v.wqe.mouseClicked(:77)
at
java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:253
)
at
java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:252
)
at
java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:252
)
at
java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:252
)
at java.awt.Component.processMouseEvent(Component.java:6266)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
at java.awt.Component.processEvent(Component.java:6028)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4630)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4460)
at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:4247)
at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at com.intellij.ide.IdeEventQueue.f(IdeEventQueue.java:610)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:496)
at
com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:368)
at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThrea
d.java:269)
at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.j
ava:184)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThrea
d.java:174)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
I am on Windows XP (32 bit).  If anyone knows about this, please
advise.  Thank you.

---
Original message URL:
http://devnet.jetbrains.net/message/5273802#5273802


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Wow!!!  Not only you are not backward compatible to your plugins, I am the one who should drive the communication between you and your 3rd party?

0

I'd agree that breaking backwards compatibility is an issue, but I also suspect
it's a fact of life for a product as complex as IDEA. Note that IDEA 9 has
been out for almost a year now, surely any third party worth their salt would
have tested and updated their plugin by now? Looking at the Visual Paradigm
website, they're still advertising the plugin as being for IDEA 6.0!!! Seems
like it's a dead/abandoned product?

http://www.visual-paradigm.com/product/sde/ij/

I don't really see how you think this is JetBrains' responsibility, beyond
them trying to minimise API changes between versions and documenting any
changes they do make. It's like asking Microsoft to chase up third parties
who've written add-ons that only work on older versions of Visual Studio.

Just my 2c

Chris

Wow!!!  Not only you are not backward compatible to your plugins, I am
the one who should drive the communication between you and your 3rd
party?



0

JetBrains does a very good job of retaining plug-in backwards compatibility. However, they do not necessary do such at the expense of preventing IDEA from moving forward

I would suspect the Visual Paradigm breakage you are experiencing occurred in IDEA 8. JetBrains did a major rework of the plug-in API in IDEA 8. (I'm pretty sure it was 8). This change was made in order to improve IDEA's plug-in capabilities, as  well as the core product itself. It allowed built in functionality to  be migrated to plug-ins so users can now select the features they want  running in IDEA. As part of that change, they

  • Provided 9 months or so of notification of the pending changes to the plug-in development community.
  • Thoroughly documented the changes and gave sample code of the changes plug-in developers needed to make.
  • Answered plug-in developer's questions in the plug-in forum. Often times providing code snippets to plug-in developers to assist them.


I use a number of plug-ins. All of them were able to make the migration smoothly thanks to JetBrains assistance. Since that major change, none of the plug-ins I use have broken in their use in IDEA 8, 9, or any of the IDEA 10 EAP builds.Thus proving their backwards compatibility.

So I humbly think your criticism of JetBrains is misplaced.

Are you sure you have the latest VP SDE version? The VP SDE for IntelliJ IDEA site shows screenshots with it running in IDEA 9.0.1 (shown in the title bar of IDEA).
See http://www.visual-paradigm.com/product/sde/ij/provides/screenshots.jsp

0

Hello Chris,

Looking at the Visual Paradigm website, they're still advertising
the plugin as being for IDEA 6.0!!! Seems like it's a dead/abandoned
product?


Apologies, I see now that the 6.0 is referring to the version of SDE, not
IDEA. Given that the latest SDE version was only released a couple of months
ago, I'd have thought it would work with IDEA 9 just fine. Have you contacted
SDE for support?


0

Please sign in to leave a comment.