977: Cannot save file: c:\boo\moo\Foo.java

All I did was edit one file and try to compile. The following error dialogue box pops up:
"Cannot save file: c:\boo\moo\Foo.java

This file was read-only

Boy, I was hoping that 977 would finally be a usable build!

Looking forward to finally testing all of the new Aurora features!

FS

17 comments

I am trying to understand what you expected the Editor to do? If the file was read only, then sure, it can't save it.

Granted, I am speaking from a slight position of previous version ignorance because I don't have read-only files in my projects. But to me it sounds the editor is doing what it's supposed to do.

0


"Patrick Burleson" <pbur@yahoo.com> wrote in message
news:12292458.1069111944082.JavaMail.itn@is.intellij.net...

I am trying to understand what you expected the Editor to do? If the file

was read only, then sure, it can't save it.
>

Granted, I am speaking from a slight position of previous version

ignorance because I don't have read-only files in my projects. But to me it
sounds the editor is doing what it's supposed to do.

The Commader of yore aka Norton Commander had a nice feature, when one
opened a read-only file in the built-in editor, updated it and was about to
save, NC reminded that file was read-only but in could still save it,
overriding read-only attribute. FAR manager, as far as I know, does the
same. Windows Commander does not just because it does not have built-in
editor. But I like the approach of "if it is prohibited but is desired a
lot, then it should be granted" ;)


0

Just double click on little lock icon in the status bar to set readonly flag
off.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Fred Smith" <allspamgone@yahoo.com> wrote in message
news:8230531.1069110921390.JavaMail.itn@is.intellij.net...

All I did was edit one file and try to compile. The following error

dialogue box pops up:

"Cannot save file: c:\boo\moo\Foo.java

>

This file was read-only

>

Boy, I was hoping that 977 would finally be a usable build!

>

Looking forward to finally testing all of the new Aurora features!

>

FS



0

I did a CVS edit command which removed the lock icon on the file tab. This should be enough for me to compile and save the file, etc. Unfortunately, when I attempt to save the file I get the error that I mentioned.

0

Update: the same thing happens if make the file writeable by double-clicking the lock icon at the bottom of the screen. The lock icon dissapears from the file tab, and I can edit the text. Unfortunately, I get an error when I try to save the file or compile.

I looked at the file attributes in Windows Explorer, and the file is writeable.

STRANGE!

0

Further update: I have the same problem if I manually change the file attributes in Windows Explorer to make the file writeable. IntelliJ gives me an error "Cannot save file c:\boo\moo\Foo.java (Access is denied)

0

Any comments from JetBrains on this bug??

0

It most probably has nothing to readonly attribute. Rather obvious that
"Access denied" message comes from operating system saying that application
(IDEA) is not permitted to write a file. Most probably those files are hold
for writing by some other application. Please check other application can
write there. (notepad?)

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Fred Smith" <allspamgone@yahoo.com> wrote in message
news:31749884.1069254930298.JavaMail.itn@is.intellij.net...

Any comments from JetBrains on this bug??



0

This is not solved in build 2250 (4.5.3). The issue doesn't come from another application. After the edit in intelij doesn't put put the file writeable.

When I use cvs on the command line, it does put the file writeable.

This is really annoying as it means the integration with CVS is really not useable.

Could you please investigate it Platform Windows NT SP6

0

I have a commercial license in the name of BNP PARIBAS and I will need your support on this issue.

0

I thought cvs didn't change the read-write flag on a file unless you told it too.

0

Maybe you selected the "use read-only flag for not edited files" option in the CVS configuration panel? If this option is marked, all files will be checked out in read only mode from CVS, and you'll need to invoke CVS -> Edit on them before making any changes.

Try unchecking this option if you don't want to bother about read only flags, or if you want to kee this flag, make sure you've called CVS -> Edit before making any changes.

0

The option"Use read only flag for not edited file " is NOT checked.

The cvs edit is done in intellij when you start to type it prompts to ask whether you want to edit the file. If yes, then it calls the internal cvs client.

I am wondering if it is a problem with supplied version of the cvs client in intellij. If I use the cygwin cvs on the command line, it works fine.

0

The cvs client which works :
$ md5sum /usr/bin/cvs
c703d9db708a823a567cfcdffea860e3 */usr/bin/cvs

Please double check the code used in cvsIntegration.jar used by IntelliJ

0

In particular, com/intellij/cvsSupport2/cvsoperations/cvsEdit/EditOperation.class
com/intellij/cvsSupport2/cvsoperations/cvsEdit/EditOperation$EditedFileInfo.class
com/intellij/cvsSupport2/cvsoperations/cvsEdit/EditorInfo.class
com/intellij/cvsSupport2/cvsoperations/cvsEdit/EditorsOperation.class
com/intellij/cvsSupport2/cvsoperations/cvsEdit/ui/EditCvsConfigurationFieldByFieldDialog.class

0

Daniel Rosenberg wrote:

I have a commercial license in the name of BNP PARIBAS and I will need your support on this issue.


Please contact support stuff at support@jetbrains.com

--
Maxim Shafirov
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

Could you please add -Dcvs.print.output=true parameter, run your IDEA with a
console, try to perform cvs edit and send me an output from the console?

--
Olesya Smirnova
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Daniel Rosenberg" <rosenberg@msit.org> wrote in message
news:19791530.1101818078837.JavaMail.itn@is.intellij.net...

This is not solved in build 2250 (4.5.3). The issue doesn't come from

another application. After the edit in intelij doesn't put put the file
writeable.
>

When I use cvs on the command line, it does put the file writeable.

>

This is really annoying as it means the integration with CVS is really not

useable.
>

Could you please investigate it Platform Windows NT SP6

>


0

Please sign in to leave a comment.