Is there a way to turn off Ctrl-MouseWheel zoom?

I've got a nice Logitec mouse with the "freewheel" feature.  This works great for scrolling through large files, but... sometimes its still spinning when I hit the control key and causes the my editor fonts to get all screwed up.  The Zoom is a nice feature, but something I need very rarely.  Is there anyway to turn that feature off?

Thx in advance.

11 comments
Comment actions Permalink

Settings -> IDE Settings group -> Editor -> Enable Ctrl+MouseWheel changes font size (in top left group "Advanced mouse usage")

John wrote:

I've got a nice Logitec mouse with the "freewheel" feature. This works great for scrolling through large files, but... sometimes its still spinning when I hit the control key and causes the my editor fonts to get all screwed up. The Zoom is a nice feature, but something I need very rarely. Is the
re anyway to turn that feature off?

Thx in advance.

---
Original message URL: http://www.jetbrains.net/devnet/message/5241943#5241943

1
Comment actions Permalink

Since upgrading to IntelliJ 9, this preference does not seem to be honored. I have it unchecked and it still zooms.  This feature is so annoying, honestly how often does anyone change the size of their code font?

I'm on a mac using a Magic Mouse.

0
Comment actions Permalink

Not seeing this, 9.0.3 on windows 7. What platform(s) are you on where this is a problem?

0
Comment actions Permalink

Mac OS X 10.6.4, IntelliJ 9.0.3

0
Comment actions Permalink

Hmmm, I wonder about the OP. Probably should file an issue in any case, if it's busted on Mac.

0
Comment actions Permalink

I am running 10.6.4 with IntelliJ 9.0.3 with a magic mouse as well and I unselected that option long ago and it works fine for me (i.e. I don't get font resize if I ctrl-scroll)

0
Comment actions Permalink

Are you talking about font resize? Or are you talking about screen zoom?

If you are talking about screen zoom then that is the OS not IntelliJ.

If you are talking about screen zoom go to System Preferences->Mouse and uncheck Screen Zoom.

0
Comment actions Permalink

I'm talking about font zoom. It happens when i am holding down "command" (not control) and my finger inadvertently glides across the "mouse wheel" area on the magic mouse.

Yes, the option is unchecked.



Attachment(s):
Screen shot 2010-09-09 at 12.35.58 PM.png
0
Comment actions Permalink

D'oh!  wrong preference.  Found the right one, I think.  I had set the image zooming.



Attachment(s):
Screen shot 2010-09-09 at 12.37.08 PM.png
0
Comment actions Permalink

Well I don't think that is your fault because there is an inconsistancy with option naming. If you search for "wheel" in preferences the only one that appears is the one regarding image zooming because that option contains "mouse wheel".

Whereas the one for font zooming is "MouseWheel" and that doesn't appear when you search for "wheel"; I guess it is only doing full word searching.

Jetbrains should have a consistent style for referring to the mouse wheel in their option names IMHO. Maybe opening an issue is in order.

0
Comment actions Permalink

That's sort of what happened -- i used the search field for 'zoom' and that was the only option that came up.  But your point about consistency with the phrase 'mousewheel' vs 'mouse wheel' makes sense.

0

Please sign in to leave a comment.