Cannot use 3075?

Hi,

I cannot use 3075 at all. It always starts with an exception thus:

java.lang.SecurityException: Prohibited package name: java.lang
at java.lang.ClassLoader.defineClass(ClassLoader.java:524)
...

I select Ignore and get:

Error message: Component requests are not allowed before they are created
java.lang.Throwable
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:34)
...

I select Ignore and it seems to be started. If I then try to do anything
like select a toolbar button or a menu option I get:

Error message: Component requests are not allowed before they are created
java.lang.Throwable
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:34)
...

Ignoring these does nothing as it always appears on the next action I try to
do? I have made a completely new install with new settings and cache and no
projects set up. But this still happens?

Any ideas would be very welcome, as I am getting very jealous hearing about
other people using the new EAP and I am unable to even get started! :(

Thanks
- scott

PS - I have submitted the exceptions to the tracker.


4 comments

I changed the -Xbootclasspath to be:

-Xbootclasspath/p:../lib/boot.jar

and this seems to have fixed these initial problems! It took a while to work
out that posts about the -Xbootclasspath were also related to my specific
problems but there you go!

Yay! I can start playing again...

- scott
"Scott Curtis" <scurtis@smart421.com> wrote in message
news:clq8nt$v1r$1@is.intellij.net...

Hi,

>

I cannot use 3075 at all. It always starts with an exception thus:

>

java.lang.SecurityException: Prohibited package name: java.lang
at java.lang.ClassLoader.defineClass(ClassLoader.java:524)
...

>

I select Ignore and get:

>

Error message: Component requests are not allowed before they are created
java.lang.Throwable
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:34)
...

>

I select Ignore and it seems to be started. If I then try to do anything
like select a toolbar button or a menu option I get:

>

Error message: Component requests are not allowed before they are created
java.lang.Throwable
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:34)
...

>

Ignoring these does nothing as it always appears on the next action I try
to do? I have made a completely new install with new settings and cache
and no projects set up. But this still happens?

>

Any ideas would be very welcome, as I am getting very jealous hearing
about other people using the new EAP and I am unable to even get started!
:(

>

Thanks
- scott

>

PS - I have submitted the exceptions to the tracker.



0

Hi,

I had exactly the same problem.
Seems to have fixed it for me. I have:
exec $IDEA_JRE/java -Didea.plugins.path=$IDEA_PLUGINS_PATH -Didea.system.path=$IDEA_SYSTEM_PATH -Didea.config.path=$IDEA_CONFIG_PATH -Didea.popup.weight=$IDEA_POPUP_WEIGHT -Didea.no.jdk.check=true -Didea.jars.nocopy=true -Xbootclasspath/p:../lib/boot.jar $JVM_ARGS $MAIN_CLASS_NAME $args

in my bin/idea.sh

I'd like to know if you're also using linux, because this seems to be a linux-only bug, nay?
I'm using kernel 2.6.9 with j2sdk-1.4.2_06... (tried it with 1.4.2_04 and 05).

Cheers,

Carlspring

0

Nope, I am using Win XP. Apparently deep within the tracker there is mention
of it being fixed in the next build?

I shall wait and see!

"Carlspring" <no_mail@jetbrains.com> wrote in message
news:2252922.1099224178085.JavaMail.itn@is.intellij.net...

Hi,

>

I had exactly the same problem.
Seems to have fixed it for me. I have:
exec
$IDEA_JRE/java -Didea.plugins.path=$IDEA_PLUGINS_PATH -Didea.system.path=$IDEA_SYSTEM_PATH
-Didea.config.path=$IDEA_CONFIG_PATH -Didea.popup.weight=$IDEA_POPUP_WEIGHT
-Didea.no.jdk.check=true -Didea.jars.nocopy=true -Xbootclasspath/p:../lib/boot.jar
$JVM_ARGS $MAIN_CLASS_NAME $args

>

in my bin/idea.sh

>

I'd like to know if you're also using linux, because this seems to be a
linux-only bug, nay?
I'm using kernel 2.6.9 with j2sdk-1.4.2_06... (tried it with 1.4.2_04 and
05).

>

Cheers,

>

Carlspring



0

Nope, I am using Win XP. Apparently deep within the
tracker there is mention
of it being fixed in the next build?


Could you have the same problem as I did last week? (See my comment in an earlier thread: http://www.intellij.net/forums/thread.jsp?forum=22&thread=112627#3407609 )

Regards,
Jens

0

Please sign in to leave a comment.