J2ME stuff

Hi!

The new J2ME stuff looks really nice! Can't wait for the next build ;)

Some gotcha's;

- cannot specify a different path & name for JAD file
(http://intellij.net/tracker/idea/viewSCR?publicId=38673)

- (linux-specific, I guess): the integration assumes a windows-based WTK
install: i.e., it tries to launch 'emulator.exe' (instead of 'emulator')
(http://intellij.net/tracker/idea/viewSCR?publicId=38676)

- cannot launch midlet from run configuration - classNotFoundException
(possibly/probably related to previous, so I didn't open a tracker request)

- Personally, I think the 'MIDlets Properties' title for the
midlet-configuration panel is confusing - I thought it was intended for
'extra' properties to go into the JAD file - not for defining the
MIDLets themselves...

- The jad file as it is being generated now won't be usable for (OTA)
deployment - the URLs specified (in fact, they're not even URLs but
local file paths...)

- Changes in the JAD file from outside IDEA are ignored (and
overwritten) - is this by design? If so, ugh. What if the file gets
updated by build scripts (for obfuscation, for example).
(http://intellij.net/tracker/idea/viewSCR?publicId=38673)

oh, and can I have the emulator view in a side-panel? (like 3rd party
j2me plugin) Saves a lot of window-switching during debugging... ;)

Regards,
Edwin

3 comments

Hi

I am unable to figure it out how to setup a Mobile Project.
Could you please explain how-to?

I am facing 2 problems
1. 1.4.2 is not valid SDk (When I compile a file)
2. Where to set Mobile SDK paths? (Getting this error in Run configuration)

Thanks in Advance
Anki.N

0

Hi,

You have to add the "mobile module" to your project and then configure the
mobile SDK in Configure JDK dialog. After that associate mobile SDK with
your mobile module. Thus, it would be the correct mobile configuration.

"Anki" <no_mail@jetbrains.com> wrote in message
news:32374108.1098905547063.JavaMail.itn@is.intellij.net...

Hi

>

I am unable to figure it out how to setup a Mobile Project.
Could you please explain how-to?

>

I am facing 2 problems
1. 1.4.2 is not valid SDk (When I compile a file)
2. Where to set Mobile SDK paths? (Getting this error in Run

configuration)
>

Thanks in Advance
Anki.N



0

Thanks

I didn't notice new Mobile SDK Icon :)

-


Anki.N

0

Please sign in to leave a comment.